Bug 964684 - kwin-gles needs a .desktop file to be switched from KDE system settings
kwin-gles needs a .desktop file to be switched from KDE system settings
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
rawhide
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-19 10:06 EDT by Massimiliano
Modified: 2015-03-06 10:56 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-06 10:56:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Massimiliano 2013-05-19 10:06:32 EDT
Description of problem:
I have installed kwin-gles:
# yum install kwin-gles

But I can switch it only manually:
$ kwin_gles --replace &

Version-Release number of selected component (if applicable):
$ rpm -q kwin-gles
kwin-gles-4.10.2-4.fc17.i686

How reproducible:
install kwin-gles in KDE desktop. It's not possible to select it from window manager selector.

Additional info:
reading this post http://weits.blogspot.it/2012/02/kwin-gles-as-default-window-manager-in.html I've created a file /usr/share/kde4/apps/ksmserver/windowmanagers/gles-wm.desktop with the following content:

[Desktop Entry]
Name=KWin GLES
Exec=kwin_gles
TryExec=kwin_gles
X-KDE-WindowManagerConfigure=systemsettings
X-KDE-WindowManagerRestartArgument=--replace

Now I can switch kwin_gles from settings.
Comment 1 Massimiliano 2013-05-19 10:13:02 EDT
I've changed the component reference to kde-settings because I can't find kwin-gles.
Comment 2 Rex Dieter 2013-05-19 10:53:58 EDT
triaging to kde-workspace
Comment 3 Rex Dieter 2015-03-06 10:56:57 EST
kwin-gles is no longer provided (in plasma5), WONTFIX

Note You need to log in before you can comment on or make changes to this bug.