Bug 964986 - Installing OpenShift Origin using file.install_origin_using_puppet.html reports error /usr/sbin/oo-mongo-setup returned 1
Installing OpenShift Origin using file.install_origin_using_puppet.html repor...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 05:04 EDT by Jan Pazdziora
Modified: 2015-05-14 22:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-29 19:46:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2013-05-20 05:04:14 EDT
Description of problem:

I try to install OpenShift Origin. I use the documentation from

   http://openshift.github.io/origin/file.install_origin_using_puppet.html

referenced from http://openshift.github.io/

Version-Release number of selected component (if applicable):

http://openshift.github.io/origin/file.install_origin_using_puppet.html and the underlying stuff as of 2013-05-20.

How reproducible:

Seen once.

Steps to Reproduce:
1. Follow the steps from http://openshift.github.io/origin/file.install_origin_using_puppet.html
2. Workaround the bug 964975 by doing mkdir /etc/puppet/modules manually.
3. Run puppet apply --verbose configure_origin.pp

Actual results:

notice: /File[/var/log/passenger-analytics]/mode: mode changed '0755' to '0750'
notice: /Stage[main]/Openshift_origin/Service[httpd]/enable: enable changed 'false' to 'true'
notice: /File[allow cartridge files through apache]/ensure: created
notice: /File[mongo setup script]/ensure: created
err: /Stage[main]/Openshift_origin::Mongo/Exec[/usr/sbin/oo-mongo-setup]/returns: change from notrun to 0 failed: /usr/sbin/oo-mongo-setup returned 1 instead of one of [0] at /etc/puppet/modules/openshift_origin/manifests/mongo.pp:105
notice: /File[/var/named]/owner: owner changed 'root' to 'named'
notice: /File[named key]/ensure: defined content as '{md5}4b80e8bf895ab9bbcc3806a30c6375e1'
notice: /File[/var/named/forwarders.conf]/ensure: defined content as '{md5}3cdd8e30219cc237a170cadccd2fd311'

Expected results:

No err: line in the output.

Additional info:

If bugzilla is not the proper way of reporting this kind of issues, please point me to better place/process.

I picked the "Broker" component for this bugzilla because the OpenShift Origin product does not seem to have "Installation" or something similar. And it felt like setting up the broker is actually the main task of the file.install_origin_using_puppet.html process.
Comment 1 Jan Pazdziora 2013-06-14 03:22:38 EDT
On Fedora 19 with the puppet install way, I don't see this error. Should this bugzilla be closed? Or do we hope to have Fedora 18 composes eventually?
Comment 2 Krishna Raman 2013-06-14 08:25:27 EDT
This tends to happen once in a while but I think I have tracked down this issue to a bug in Facter. The ipaddress fact in F19 is broken and due to that mongo doesnt start (broken config). I will close this issue and link to the Facter one.
Comment 3 Krishna Raman 2013-12-09 18:31:56 EST
Issue is fixed in latest builds.
Comment 4 chunchen 2014-01-20 03:46:08 EST
It's fixed, checked on a fresh installed Fedora 19 system, so mark it as VERIFIED since there did not meet the related errors, please refer to the following results:

1. Follow the steps from http://openshift.github.io/documentation/oo_deployment_guide_puppet.html

2.  Run puppet apply --verbose configure_origin.pp
# puppet apply --verbose configure_origin.pp | grep -i -e error -e err

Warning: Config file /etc/puppet/hiera.yaml not found, using Hiera defaults
Warning: Augeas[network-scripts](provider=augeas): Loading failed for one or more files, see debug for /augeas//error output
<-------snip---->

Note You need to log in before you can comment on or make changes to this bug.