Bug 965015 - "pkg-config --variable=sdkdir libxul" exits prematurely on rhel6.4
"pkg-config --variable=sdkdir libxul" exits prematurely on rhel6.4
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pkgconfig (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Colin Walters
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 06:17 EDT by Andrei Maslennikov
Modified: 2017-12-06 06:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 06:39:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of strace pkg-config --variable=libdir libxul (3.01 KB, text/plain)
2013-05-20 06:17 EDT, Andrei Maslennikov
no flags Details

  None (edit)
Description Andrei Maslennikov 2013-05-20 06:17:18 EDT
Created attachment 750485 [details]
Output of strace pkg-config --variable=libdir libxul

Description of problem:
------------------------------

I was trying to rebuild the firefox RPM on official RHEL 6.4. The build was failing and I traced it to an incorrect behavior of the pkg-config command.

Current version of pkgconfig: pkgconfig-0.23-9.1.el6.x86_64.

In more detail, the commands

"pkg-config --variable=sdkdir libxul" or 
"pkg-config --variable=libdir libxul"

exit prematurely without reporting nothing. 

On this machine I have the appropriate xulrunner rpms installed:
xulrunner-devel-17.0.6-2.el6_4.x86_64
xulrunner-17.0.6-2.el6_4.x86_64

And the file "libxul.pc" contains all the necessary information:

# cat /usr/lib64/pkgconfig/libxul.pc
prefix=/usr
sdkdir=/usr/lib64/xulrunner-devel-17.0.6
includedir=/usr/include/xulrunner-17.0.6
idldir=/usr/share/idl/xulrunner-17.0.6
libdir=/usr/lib64/xulrunner

Name: libxul
Description: The Mozilla Runtime and Embedding Engine
Version: 17.0.6
Requires: nspr >= 4.9.5
Libs: -L${sdkdir}/lib -lxpcomglue_s -lxul -lxpcom -lmozalloc
Cflags: -I${includedir} -fshort-wchar


How reproducible:
---------------------------------
Reproducible in 100% of cases.


Additional info:
----------------------------------
I attach to this bug report the output of 
strace pkg-config --variable=libdir libxul
Comment 1 Tomas Pelka 2013-05-20 07:00:20 EDT
Yes this is expected since the new nss/nspr is still pending.

It will disappear once nss/nspr are out.
Comment 3 Andrei Maslennikov 2013-05-31 11:24:07 EDT
Right, 

so when the new nss/nspr are due? The last update was in January-February 2013...

Could you comment on this? Thanks ahead!
Comment 4 RHEL Product and Program Management 2013-10-13 19:35:58 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 5 Jan Kurik 2017-12-06 06:39:21 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.