Bug 965017 - cannot show the web cartridge status message via rhc cartridge-status only for jbossews-1.0/2.0
cannot show the web cartridge status message via rhc cartridge-status only fo...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
All All
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 06:28 EDT by zhaozhanqi
Modified: 2015-05-14 19:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 11:15:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhaozhanqi 2013-05-20 06:28:08 EDT
Description of problem:
create a scale or non-scaling jbossews-1.0/2.0, run 'rhc cartridge status -a $appnem -c jbossews-1.0' the result not correct.

Version-Release number of selected component (if applicable):
devenv_3246

How reproducible:
always

Steps to Reproduce:
1.create an jbossews app
2.rhc cartridge status -a $appnem -c jbossews-1.0
3.

Actual results:
[zqzhao@dhcp-13-222 non_scalable]$ rhc cartridge status -a zqjbossews20 -c jbossews-2.0
RESULT:
tailing
------ Tail of JBoss catalina.out ------
May


Expected results:

should show like "application is running."

Additional info:
Comment 1 Dan Mace 2013-05-20 09:16:01 EDT
The current status behavior (which shows the log tail) is actually identical to the V1 cartridge implementation. I'll determine whether the behavior is expected to be changed for the V2 implementation, and will either close this as not a bug or send it back to QE with revised behavior.
Comment 2 Xiaoli Tian 2013-05-20 10:31:35 EDT
(In reply to Dan Mace from comment #1)
> The current status behavior (which shows the log tail) is actually identical
> to the V1 cartridge implementation. I'll determine whether the behavior is
> expected to be changed for the V2 implementation, and will either close this
> as not a bug or send it back to QE with revised behavior.

The  problem here is seems it even does not tail the logs correctly like v1, the following is the full result returned:

RESULT:
tailing
------ Tail of JBoss catalina.out ------
May

But the content in catalina.out is like following:
[zqjews1-zqd.dev.rhcloud.com logs]\> cat catalina.out
May 20, 2013 3:52:53 AM org.apache.catalina.startup.ClusterRuleSetFactory getClusterRuleSet
INFO: Unable to find a cluster rule set in the classpath. Will load the default rule set.
May 20, 2013 3:52:53 AM org.apache.catalina.startup.ClusterRuleSetFactory getClusterRuleSet
INFO: Unable to find a cluster rule set in the classpath. Will load the default rule set.
May 20, 2013 3:52:53 AM org.apache.catalina.core.AprLifecycleListener init
INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/java/packages/lib/i386:/lib:/usr/lib
May 20, 2013 3:52:53 AM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on http-127.5.126.129-8080
May 20, 2013 3:52:53 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 623 ms
May 20, 2013 3:52:53 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
May 20, 2013 3:52:53 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/6.0.35
May 20, 2013 3:52:53 AM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive ROOT.war
May 20, 2013 3:52:54 AM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on http-127.5.126.129-8080
May 20, 2013 3:52:54 AM org.apache.catalina.startup.Catalina start
INFO: Server startup in 414 ms
Comment 3 Liang Xia 2013-07-03 01:34:16 EDT
Upgrade severity to medium.
List the output of jbossas-7 & jbosseap-6.0 for your reference.

$ rhc cartridge status jbossas -a as
Using jbossas-7 (JBoss Application Server 7) for 'jbossas'

RESULT:
Application is running
$ rhc cartridge status jbosseap -a eap
Using jbosseap-6.0 (JBoss Enterprise Application Platform 6.0) for 'jbosseap'

RESULT:
Application is running




$ rhc cartridge status jbossews -a ews1
Using jbossews-1.0 (Tomcat 6 (JBoss EWS 1.0)) for 'jbossews'

RESULT:
tailing
------ Tail of JBoss catalina.out ------
Jul
$ rhc cartridge status jbossews -a ews2
Using jbossews-2.0 (Tomcat 7 (JBoss EWS 2.0)) for 'jbossews'

RESULT:
tailing
------ Tail of JBoss catalina.out ------
Jul
Comment 4 Dan Mace 2013-07-08 16:46:50 EDT
https://github.com/openshift/origin-server/pull/3008

I removed the nonsensical tail output from the status call and replaced it with a meaningful message.
Comment 5 openshift-github-bot 2013-07-09 00:12:16 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/0e083fb45a8d2a96d921b12a83633c7c5ace227e
Bug 965017: Improve jbossews control status message
Comment 6 zhaozhanqi 2013-07-09 05:47:43 EDT
Tested this bug on devenv_3464, it has been fixed.


 $ rhc cartridge status -a zqjbossews10 -c jbossews
Using jbossews-1.0 (Tomcat 6 (JBoss EWS 1.0)) for 'jbossews'

RESULT:
The jbossews cartridge is running.


$ rhc cartridge status -a zqjbossews20 -c jbossews
Using jbossews-2.0 (Tomcat 7 (JBoss EWS 2.0)) for 'jbossews'

RESULT:
The jbossews cartridge is running.

Note You need to log in before you can comment on or make changes to this bug.