Bug 965146 - SELinux is preventing /usr/sbin/saslauthd from name_connect
SELinux is preventing /usr/sbin/saslauthd from name_connect
Status: CLOSED DUPLICATE of bug 896032
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.0
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 10:14 EDT by David Spurek
Modified: 2015-03-02 00:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-22 02:44:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Spurek 2013-05-20 10:14:23 EDT
Description of problem:
Selinux is preventing/usr/sbin/saslauthd from name_connect

time->Tue May 14 14:35:05 2013
type=SYSCALL msg=audit(1368556505.832:539): arch=c000003e syscall=42 success=no exit=-13 a0=8 a1=7f489aaae340 a2=1c a3=7fffe51e7c60 items=0 ppid=7047 pid=7049 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm="saslauthd" exe="/usr/sbin/saslauthd" subj=system_u:system_r:saslauthd_t:s0 key=(null)
type=AVC msg=audit(1368556505.832:539): avc:  denied  { name_connect } for  pid=7049 comm="saslauthd" dest=389 scontext=system_u:system_r:saslauthd_t:s0 tcontext=system_u:object_r:ldap_port_t:s0 tclass=tcp_socket
----
time->Tue May 14 14:35:05 2013
type=SYSCALL msg=audit(1368556505.833:540): arch=c000003e syscall=42 success=no exit=-13 a0=8 a1=7f489aaae2f0 a2=10 a3=0 items=0 ppid=7047 pid=7049 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm="saslauthd" exe="/usr/sbin/saslauthd" subj=system_u:system_r:saslauthd_t:s0 key=(null)
type=AVC msg=audit(1368556505.833:540): avc:  denied  { name_connect } for  pid=7049 comm="saslauthd" dest=389 scontext=system_u:system_r:saslauthd_t:s0 tcontext=system_u:object_r:ldap_port_t:s0 tclass=tcp_socket
----
time->Tue May 14 14:35:05 2013
type=SYSCALL msg=audit(1368556505.833:541): arch=c000003e syscall=42 success=no exit=-13 a0=8 a1=7f489aaae220 a2=1c a3=0 items=0 ppid=7047 pid=7049 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm="saslauthd" exe="/usr/sbin/saslauthd" subj=system_u:system_r:saslauthd_t:s0 key=(null)
type=AVC msg=audit(1368556505.833:541): avc:  denied  { name_connect } for  pid=7049 comm="saslauthd" dest=389 scontext=system_u:system_r:saslauthd_t:s0 tcontext=system_u:object_r:ldap_port_t:s0 tclass=tcp_socket
----
time->Tue May 14 14:35:05 2013
type=SYSCALL msg=audit(1368556505.833:542): arch=c000003e syscall=42 success=no exit=-13 a0=8 a1=7f489aaa0700 a2=10 a3=0 items=0 ppid=7047 pid=7049 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm="saslauthd" exe="/usr/sbin/saslauthd" subj=system_u:system_r:saslauthd_t:s0 key=(null)
type=AVC msg=audit(1368556505.833:542): avc:  denied  { name_connect } for  pid=7049 comm="saslauthd" dest=389 scontext=system_u:system_r:saslauthd_t:s0 tcontext=system_u:object_r:ldap_port_t:s0 tclass=tcp_socket
Fail: AVC messages found.
Checking for errors...
Using stronger AVC checks.
	Define empty RHTS_OPTION_STRONGER_AVC parameter if this causes any problems.
Running 'cat /mnt/testarea/tmp.rhts-db-submit-result.T5qg5p | /sbin/ausearch -m AVC -m SELINUX_ERR'
Fail: AVC messages found.
Running 'cat %s | /sbin/ausearch -m USER_AVC >/mnt/testarea/tmp.rhts-db-submit-result.I62epG 2>&1'
Info: No AVC messages found.
/bin/grep 'avc: ' /mnt/testarea/dmesg.log | /bin/grep --invert-match TESTOUT.log
No AVC messages found in dmesg
Running '/usr/sbin/sestatus'
SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
SELinux root directory:         /etc/selinux
Loaded policy name:             targeted
Current mode:                   enforcing
Mode from config file:          enforcing
Policy MLS status:              enabled
Policy deny_unknown status:     allowed
Max kernel policy version:      28
Running 'rpm -q selinux-policy || true'
selinux-policy-3.12.1-38.el7.noarch


Version-Release number of selected component (if applicable):
selinux-policy-3.12.1-38.el7.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Milos Malik 2013-05-21 04:26:39 EDT
This bug is a duplicate of bz#896032.
Comment 3 Miroslav Grepl 2013-05-22 02:44:09 EDT

*** This bug has been marked as a duplicate of bug 896032 ***

Note You need to log in before you can comment on or make changes to this bug.