Bug 965204 - On Dashboard: (GET /candlepin/owners/CNO/info) (RestClient::ResourceNotFound) after update to 1.3.30-1
On Dashboard: (GET /candlepin/owners/CNO/info) (RestClient::ResourceNotFound)...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Walden Raines
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 13:35 EDT by robert.redhat
Modified: 2014-09-18 11:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-06 12:45:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
katello-debug (10.64 MB, application/x-gzip)
2013-05-20 13:35 EDT, robert.redhat
no flags Details

  None (edit)
Description robert.redhat 2013-05-20 13:35:49 EDT
Created attachment 750662 [details]
katello-debug

Description of problem:
I have two virtually identical servers. I updated both to 1.3.30-1 from 1.3.24 and now get the following error on one server but not the other:
(GET /candlepin/owners/CNO/info) (RestClient::ResourceNotFound)


Version-Release number of selected component (if applicable):
katello-all-1.3.30-1.el6.noarch
katello-1.3.30-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
candlepin-0.8.5-1.el6.noarch
candlepin-tomcat6-0.8.5-1.el6.noarch
candlepin-cert-consumer-lxyump01-1.0-1.noarch
candlepin-selinux-0.8.5-1.el6.noarch
katello-glue-candlepin-1.3.30-1.el6.noarch


How reproducible:
Unsure, as this happens on one server and not another.
Comment 1 Walden Raines 2013-06-06 14:56:43 EDT
Robert,

What is the result of the following SQL query (psql -U candlepin):

SELECT o.account, e.name FROM cp_environment e
JOIN cp_owner o ON (e.owner_id = o.id)
WHERE o.account ILIKE '%CNO%';

Just want to make sure the owner and environment are there.

Thanks,
Walden
Comment 2 robert.redhat 2013-06-06 15:15:57 EDT
Walden,

I ended up having to do 'katello-configure --reset-data=yes' yesterday in order to be ready for a patch push tomorrow, so I can't run this SQL query.

I can say that psql -U candlepin would ask for a password as I was trying to run some queries against the candlepin database.

I can also say the CNO did show up in the dashboard. I think this may have been caused by an environment that I tried to delete and did not succeed.

Thanks for looking into it.

Rob
Comment 3 Bryan Kearney 2014-01-21 14:07:29 EST
Moving to Sat6 to be tracked there. Upstream bugs are moving to redmine.
Comment 4 Walden Raines 2014-03-06 12:09:35 EST
(In reply to robert.redhat from comment #2)
> Walden,
> 
> I ended up having to do 'katello-configure --reset-data=yes' yesterday in
> order to be ready for a patch push tomorrow, so I can't run this SQL query.
> 
> I can say that psql -U candlepin would ask for a password as I was trying to
> run some queries against the candlepin database.
> 
> I can also say the CNO did show up in the dashboard. I think this may have
> been caused by an environment that I tried to delete and did not succeed.
> 
> Thanks for looking into it.
> 
> Rob

Rob,

Can you confirm whether or not you are still experiencing this issue?

Thanks,
Walden
Comment 5 robert.redhat 2014-03-06 12:27:45 EST
Walden,

I am no long at that company. However, I had moved on to 1.4 (I believe) before leaving. This ticket can probably be closed.

Rob
Comment 6 Walden Raines 2014-03-06 12:45:56 EST
Rob,

Thanks for the quick reply.

Cheers,
Walden

Note You need to log in before you can comment on or make changes to this bug.