Bug 9653 - gnome tree can't be opened with '+' and de-keyboard layout
gnome tree can't be opened with '+' and de-keyboard layout
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gtk+ (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-21 13:27 EST by Harald Hoyer
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-11 09:06:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2000-02-21 13:27:42 EST
gnome tree widget can be opened by '+' and
 Section "Keyboard"
     Protocol    "Standard"
     LeftAlt         Meta
     RightAlt        Meta
     ScrollLock      Compose
     RightCtl        Control
     XkbRules    "xfree86"
     XkbModel    "pc102"
     XkbLayout   "de"
     XkbVariant  "nodeadkeys"
 EndSection

 it can only be closed by '-'
 tested with gnomecc ... :(
Comment 1 Preston Brown 2000-02-23 21:25:59 EST
havoc:  can you make heads or tails of what this means?
Comment 2 Havoc Pennington 2000-02-24 17:33:59 EST
Can you explain in more detail? Is the problem that the "+" key doesn't expand
tree nodes? Are you using "+" on the numeric keypad, or regular "+"?
Comment 3 Harald Hoyer 2000-02-25 02:43:59 EST
I did use the regular +, the numeric didn't come in my mind. :)
Comment 4 Havoc Pennington 2000-02-25 12:01:59 EST
So for me "+" expands, "-" collapses, and "=" toggles the state. "+" just does
nothing for you? What keysym does your "+" send?
Comment 5 Harald Hoyer 2000-02-28 08:56:59 EST
KeyPress event, serial 30, synthetic NO, window 0x3800001,
    root 0x26, subw 0x0, time 2558882897, (91,86), root:(1188,871),
    state 0x0, keycode 35 (keysym 0x2b, plus), same_screen YES,
    XLookupString gives 1 characters:  "+"

KeyRelease event, serial 30, synthetic NO, window 0x3800001,
    root 0x26, subw 0x0, time 2558882964, (91,86), root:(1188,871),
    state 0x0, keycode 35 (keysym 0x2b, plus), same_screen YES,
    XLookupString gives 1 characters:  "+"
--------
Numeric "+" works with no problems
Comment 6 Havoc Pennington 2000-02-29 14:58:59 EST
OK, I know why this problem happens: basically the keybinding is "Shift and the
plus key," rather than simply "the plus keysym." It's a GTK bug, so I'll move it
to GTK.
Comment 7 Harald Hoyer 2000-11-03 09:11:39 EST
Does this ever get fixed???
Comment 8 Owen Taylor 2001-07-10 18:06:54 EDT
It's quite hard to fix since it takes sensitivity
to the keyboard layout to know what to do. We will have
this fixed for GTK+-2.0.
Comment 9 Harald Hoyer 2001-07-11 04:35:51 EDT
XLookupString gives 1 characters:  "+"
doesn't that work with all layouts?
Comment 10 Owen Taylor 2001-07-11 09:05:57 EDT
The question is, is <Shift> an ignorable modifier for a given accelerator?

For '+' it is, for 'F1' it is not. Knowing which is the case for a 
particular accelerator key, takes sensitivity to the keyboard layout.

Of course, in this case, there is a simple workaround:

Fri Feb 16 20:09:42 2001 Owen Taylor <otaylor@redhat.com>

* gtk/gtkctree.c (gtk_ctree_class_init): Add bindings
for unshifted + and shifted = for non-us keyboards.
Make <Control>+ and <Control>- work as well as
<Control>KP_Plus, <Control>KP_Minus for recursive
open/close. (#2682, Reni Seindal)

Which was in 1.2.9 / 7.1. :-)

Note You need to log in before you can comment on or make changes to this bug.