Bug 965309 - Error: Protected multilib versions: python-2.7.5-1.fc19.x86_64 != python-2.7.4-4.fc19.i686
Error: Protected multilib versions: python-2.7.5-1.fc19.x86_64 != python-2.7....
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Bohuslav "Slavek" Kabrda
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 17:14 EDT by Paul Finnigan
Modified: 2013-06-04 23:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 13:07:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
out put from "rpm -qa | grep python | sort" (3.14 KB, text/plain)
2013-05-23 17:49 EDT, Paul Finnigan
no flags Details
output from "yum update -y --skip-broken" (21.91 KB, text/plain)
2013-05-23 17:51 EDT, Paul Finnigan
no flags Details

  None (edit)
Description Paul Finnigan 2013-05-20 17:14:52 EDT
Description of problem:
Yum update -y

Fails:

Error: Protected multilib versions: python-2.7.5-1.fc19.x86_64 != python-2.7.4-4.fc19.i686


I have no python i686 packages installed.

Version-Release number of selected component (if applicable):

python-2.7.5-1.fc19.x86_64

How reproducible: everytime

Steps to Reproduce:
1. Yum update -y


Actual results:
Error: Protected multilib versions: python-2.7.5-1.fc19.x86_64 != python-2.7.4-4.fc19.i686

Expected results:
Packages updated

Additional info:
Comment 1 Bohuslav "Slavek" Kabrda 2013-05-21 05:23:22 EDT
That is strange. Could you please attach output of

rpm -qa | grep python | sort

Could you also paste the set of packages that yum is trying to update? Maybe the i686 package is being drawn their as a dependency of something.

Thanks.
Comment 2 Paul Finnigan 2013-05-23 17:49:06 EDT
Created attachment 752398 [details]
out put from "rpm -qa | grep python | sort"

As requested.
Comment 3 Paul Finnigan 2013-05-23 17:51:14 EDT
Created attachment 752399 [details]
output from "yum update -y --skip-broken"

Output from yum, note in the meantime samba has a dependency problem that required the skip-broken.
Comment 4 Bohuslav "Slavek" Kabrda 2013-05-24 02:01:56 EDT
I think this is caused by not-yet-updated version of python-docs. Python is 2.7.5, but python-docs are still 2.7.4 and they require Python of precisely same version. So when you try to update, Python 2.7.5 is marked for update, but python-docs need 2.7.4. I will update python-docs asap and we'll see if it solves the problem.
Comment 5 Fedora Update System 2013-05-24 03:00:24 EDT
python-docs-2.7.5-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/python-docs-2.7.5-1.fc19
Comment 6 Paul Finnigan 2013-05-27 16:51:18 EDT
python-docs-2.7.5-1.fc19 installed and problem goes away.

Thanks
Comment 7 Fedora Update System 2013-06-04 23:14:58 EDT
python-docs-2.7.5-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.