Bug 965319 - ruby193-puppet tries managing "puppet" service: error reading information on service puppet
ruby193-puppet tries managing "puppet" service: error reading information on ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Dominic Cleal
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 18:37 EDT by Dominic Cleal
Modified: 2013-07-18 17:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:18:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominic Cleal 2013-05-20 18:37:10 EDT
Description of problem:
When installing ruby193-puppet (as a dependency of katello-foreman-all), the following message is shown:

Installing : ruby193-puppet-3.1.1-16.el6sat.noarch
error reading information on service puppet: No such file or directory

The package installs the service script as "ruby193-puppet", but the post install snippet refers to just "puppet":

# rpm -ql ruby193-puppet | grep init
/etc/rc.d/init.d/ruby193-puppet

# rpm -q --scripts ruby193-puppet | grep chkconfig
/sbin/chkconfig --add puppet || :
  /sbin/chkconfig --del puppet || :

Same when erasing the package.

This will prevent the Puppet agent from being used on any host.

Version-Release number of selected component (if applicable):
ruby193-puppet-3.1.1-16.el6sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. yum install ruby193-puppet

Actual results:
error reading information on service puppet: No such file or directory

Expected results:
no error
Comment 1 Dominic Cleal 2013-06-19 04:45:44 EDT
Fixed upstream in ruby193-puppet:
http://koji.katello.org/koji/buildinfo?buildID=4939

* Wed Jun 19 2013 Dominic Cleal <dcleal@redhat.com> 3.1.1-16 - fix non-SCL references to services in scriptlets (dcleal@redhat.com)
* Tue May 21 2013 Miroslav Suchý <msuchy@redhat.com> 3.1.1-14 - service script on SCL should be prefixed with scl_prefix (msuchy@redhat.com)

Respective SHAs:
50876551943209ae048dfe989e8b8088105273a8
03e68db42eace6d963239f0cb0f6e2710793aa71
Comment 2 Brad Buckingham 2013-06-21 08:59:38 EDT
Mass move to ON_QA
Comment 3 Og Maciel 2013-06-22 18:52:22 EDT
Looks like we still need a bit of work:

  Installing : ruby193-puppet-3.1.1-19.el6sat.noarch                                                               282/338
error reading information on service puppet: No such file or directory
  Installing : foreman-1.1.10014-1.noarch                                                                          283/338

# rpm -ql ruby193-puppet | grep init
/etc/rc.d/init.d/ruby193-puppet
/opt/rh/ruby193/root/usr/share/emacs/site-lisp/site-start.d/puppet-mode-init.el
/opt/rh/ruby193/root/usr/share/ruby/vendor_ruby/puppet/module_tool/skeleton/templates/generator/manifests/init.pp.erb
/opt/rh/ruby193/root/usr/share/ruby/vendor_ruby/puppet/module_tool/skeleton/templates/generator/tests/init.pp.erb
/opt/rh/ruby193/root/usr/share/ruby/vendor_ruby/puppet/parser/ast/definition.rb
/opt/rh/ruby193/root/usr/share/ruby/vendor_ruby/puppet/provider/service/init.rb

# rpm -q --scripts ruby193-puppet | grep chkconfig
/sbin/chkconfig --add puppet || :
  /sbin/chkconfig --del ruby193-puppet || :
Comment 4 Og Maciel 2013-06-22 18:53:29 EDT
This fails QE:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10014-1.noarch
* foreman-compute-1.1.10014-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10014-1.noarch
* foreman-postgresql-1.1.10014-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-10.f5ae2cd.el6sat.noarch
* katello-1.4.2-17.el6sat.noarch
* katello-all-1.4.2-17.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-8.el6sat.noarch
* katello-cli-common-1.4.2-8.el6sat.noarch
* katello-common-1.4.2-17.el6sat.noarch
* katello-configure-1.4.3-16.el6sat.noarch
* katello-configure-foreman-1.4.3-16.el6sat.noarch
* katello-foreman-all-1.4.2-17.el6sat.noarch
* katello-glue-candlepin-1.4.2-17.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-17.el6sat.noarch
* katello-glue-pulp-1.4.2-17.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.2-1.el6sat.noarch
* pulp-selinux-2.1.2-1.el6sat.noarch
* pulp-server-2.1.2-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* ruby193-rubygem-runcible-0.4.10-1.el6sat.noarch
* signo-0.0.19-1.el6sat.noarch
* signo-katello-0.0.19-1.el6sat.noarch
Comment 5 Brad Buckingham 2013-06-24 17:25:40 EDT
Mass move to ON_QA
Comment 6 Og Maciel 2013-06-24 17:40:40 EDT
Verified:
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10014-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-postgresql-1.1.10014-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-10.f5ae2cd.el6sat.noarch
* katello-1.4.2-18.el6sat.noarch
* katello-all-1.4.2-18.el6sat.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-8.el6sat.noarch
* katello-cli-common-1.4.2-8.el6sat.noarch
* katello-common-1.4.2-18.el6sat.noarch
* katello-configure-1.4.3-16.el6sat.noarch
* katello-configure-foreman-1.4.3-16.el6sat.noarch
* katello-foreman-all-1.4.2-18.el6sat.noarch
* katello-glue-candlepin-1.4.2-18.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-18.el6sat.noarch
* katello-glue-pulp-1.4.2-18.el6sat.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.2-1.el6sat.noarch
* pulp-selinux-2.1.2-1.el6sat.noarch
* pulp-server-2.1.2-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* ruby193-rubygem-runcible-0.4.10-1.el6sat.noarch
* signo-0.0.19-1.el6sat.noarch
* signo-katello-0.0.19-1.el6sat.noarch
Comment 7 Mike McCune 2013-07-18 17:18:09 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.