Bug 965334 - SELinux is preventing /usr/libexec/mission-control-5 from 'write' accesses on the file user.
SELinux is preventing /usr/libexec/mission-control-5 from 'write' accesses on...
Status: CLOSED DUPLICATE of bug 906211
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f445b939ae9d9c0e26f3a00c49e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 20:26 EDT by vinesh teotia
Modified: 2013-05-21 06:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 06:35:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vinesh teotia 2013-05-20 20:26:09 EDT
Description of problem:
SELinux is preventing /usr/libexec/mission-control-5 from 'write' accesses on the file user.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that mission-control-5 should be allowed write access on the user file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep mission-control /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:config_home_t:s0
Target Objects                user [ file ]
Source                        mission-control
Source Path                   /usr/libexec/mission-control-5
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           telepathy-mission-control-5.14.1-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.2-301.fc19.x86_64 #1 SMP Mon
                              May 13 12:36:24 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-20 17:26:17 IST
Last Seen                     2013-05-20 17:26:17 IST
Local ID                      9c0f9cf7-3bbf-4986-8c24-b17cd310ab0d

Raw Audit Messages
type=AVC msg=audit(1369050977.195:504): avc:  denied  { write } for  pid=6706 comm="mission-control" name="user" dev="tmpfs" ino=68142 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:config_home_t:s0 tclass=file


type=SYSCALL msg=audit(1369050977.195:504): arch=x86_64 syscall=open success=yes exit=E2BIG a0=204fbe0 a1=42 a2=180 a3=7fff62f8b0f0 items=0 ppid=1 pid=6706 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 ses=4294967295 tty=(none) comm=mission-control exe=/usr/libexec/mission-control-5 subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: mission-control,xdm_dbusd_t,config_home_t,file,write

audit2allow

#============= xdm_dbusd_t ==============
allow xdm_dbusd_t config_home_t:file write;

audit2allow -RYou must regenerate interface info by running /usr/bin/sepolgen-ifgen


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.2-301.fc19.x86_64
type:           libreport

Potential duplicate: bug 906211
Comment 1 Miroslav Grepl 2013-05-21 06:35:02 EDT

*** This bug has been marked as a duplicate of bug 906211 ***

Note You need to log in before you can comment on or make changes to this bug.