Bug 965364 - Downloadable cart with no usr/template dir fails on creation, no message reported to client
Downloadable cart with no usr/template dir fails on creation, no message repo...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: 2.x
Assigned To: Jhon Honce
libra bugs
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-20 23:29 EDT by Clayton Coleman
Modified: 2015-07-07 19:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-07 19:48:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2013-05-20 23:29:58 EDT
Create a custom cart with no usr/template directory.  The git archive command fails when trying to deploy the custom cart, which prevents the cart from being installed.

The actual error "No such file or directory chdir" should be logged a minimum, but it also shouldn't fail.

Creating application 'foo2' ... 
Unable to complete the requested operation due to: Node execution failure (invalid exit code from node).
 If the problem persists please contact Red Hat support..
Reference ID: 02ac00ae9f0419f23562ee39ecd4386d

---| Broker development.log |-----------------

2013-05-20 23:23:44.710 [DEBUG] DEBUG: server results: No such file or directory - chdir (pid:600)
2013-05-20 23:23:44.710 [ERROR] Node execution failure (invalid exit code from node).  If the problem pe
rsists please contact Red Hat support. (pid:600)
2013-05-20 23:23:44.712 [ERROR] ["/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-m
collective-1.9.2/lib/openshift/mcollective_application_container_proxy.rb:2614:in `parse_result'", "/opt
/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.9.2/lib/openshift/mcollec
tive_application_container_proxy.rb:2762:in `run_cartridge_command'", "/var/www/openshift/broker/lib/onl
ine/broker/mcollective_ext.rb:13:in `run_cartridge_command'", "/opt/rh/ruby193/root/usr/share/gems/gems/
openshift-origin-msg-broker-mcollective-1.9.2/lib/openshift/mcollective_application_container_proxy.rb:7
21:in `configure_cartridge'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.9.
2/app/models/gear.rb:123:in `add_component'", "/opt/rh/ruby193/root/us


---| Node platform-trace |-----------------

D, [2013-05-20T23:23:43.646740 #387] DEBUG -- : oo_spawn running /sbin/runuser -m -s /bin/sh cf9c99c0c1c511e29a3b12313d17097d -c "exec /usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c0,c502' /bin/sh -c \"/var/lib/openshift/cf9c99c0c1c511e29a3b12313d17097d/cdk/bin/install --version 1.0\"": {:unsetenv_others=>true, :close_others=>true, :in=>"/dev/null", :chdir=>"/var/lib/openshift/cf9c99c0c1c511e29a3b12313d17097d/", :out=>#<IO:fd 11>, :err=>#<IO:fd 9>}
D, [2013-05-20T23:23:44.653169 #387] DEBUG -- : oo_spawn running /sbin/runuser -m -s /bin/sh cf9c99c0c1c511e29a3b12313d17097d -c "exec /usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c0,c502' /bin/sh -c \"set -xe;
shopt -s dotglob;
rm -rf /var/lib/openshift/cf9c99c0c1c511e29a3b12313d17097d/app-root/runtime/repo/*;
git archive --format=tar HEAD | (cd /var/lib/openshift/cf9c99c0c1c511e29a3b12313d17097d/app-root/runtime/repo && tar --warning=no-timestamp -xf -);
\"": {:unsetenv_others=>false, :close_others=>true, :in=>"/dev/null", :chdir=>"/var/lib/openshift/cf9c99c0c1c511e29a3b12313d17097d/git/foo2.git", :out=>#<IO:fd 11>, :err=>#<IO:fd 9>}
D, [2013-05-20T23:23:44.677726 #387] DEBUG -- : oo_spawn running cgset -r cpu.cfs_quota_us=30000 /openshift/cf9c99c0c1c511e29a3b12313d17097d: {:unsetenv_others=>false, :close_others=>true, :in=>"/dev/null", :out=>#<IO:fd 11>, :err=>#<IO:fd 9>}
Comment 1 Jhon Honce 2013-05-21 22:47:41 EDT
Fixed in https://github.com/openshift/origin-server/pull/2584
Comment 2 openshift-github-bot 2013-05-22 00:06:03 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/72fb39d3bdb6ab44548aa3b05df682abe086879d
Bug 965364 - ApplicationRepository#deploy assumed template application existed

* Put guards and messaging in place for use case where cartridge did not provide application template
Comment 3 Xiaoli Tian 2013-05-22 04:44:36 EDT
Reproduced it on INT(devenv_3250).
Verified it on devenv_3258 by removing usr/template from the custom cartridge if exsting.


It could be created successfully.

#rhc app-create perl2 https://raw.github.com/xltian/perltestonly/master/metadata/manifest.yml
The cartridge 'https://raw.github.com/xltian/perltestonly/master/metadata/manifest.yml' will be downloaded and installed

Application Options
-------------------
  Namespace:  domx1
  Cartridges: https://raw.github.com/xltian/perltestonly/master/metadata/manifest.yml
  Gear Size:  default
  Scaling:    no

Creating application 'perl2' ... done

Waiting for your DNS name to be available ... done
Comment 4 Chris Ryan 2015-04-08 12:53:20 EDT
I'm still seeing the original behavior on devenv_5493 (ami-d689bbbe), which is I'm unable to create an app and I get a Reference ID.

I created a repo based off of the original devenv cartridge:
https://github.com/openshift-qe/missing_template

This is the result:

      The cartridge 'https://raw.githubusercontent.com/openshift-qe/missing_template/master/metadata/manifest.yml' will be downloaded and installed
      
      Application Options
      -------------------
      Domain:     lnpgf1
      Cartridges: https://raw.githubusercontent.com/openshift-qe/missing_template/master/metadata/manifest.yml
      Gear Size:  small
      Scaling:    no
      
      Creating application 'mbhqkkky' ... Unable to complete the requested operation due to: An invalid exit code (1) was returned from the server ip-10-229-27-180.  This indicates an unexpected problem during the execution of your request.
      Reference ID: e3dce313e69350b2edd5261842997025
Comment 5 Jhon Honce 2015-06-16 20:27:31 EDT
Fixed in https://github.com/openshift/origin-server/pull/6171
Comment 6 openshift-github-bot 2015-06-17 22:30:00 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/3bfee1212503606edb4957adc3ac3751105ece73
Bug 965364 - Restore creating gear with no git template
Comment 7 Chris Ryan 2015-06-18 18:39:24 EDT
Verified on devenv-5554. The above fix works; I no longer see the "Reference ID:" error, and the $OPENSHIFT_REPO_DIR/php.log now shows a 404 for the main url, as expected.

Note You need to log in before you can comment on or make changes to this bug.