Bug 965383 - Unwanted desktop icons
Unwanted desktop icons
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nemo (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 02:03 EDT by Tom
Modified: 2013-08-07 06:40 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 12:52:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Icon on desktop with tweak tool (130.21 KB, image/png)
2013-05-21 02:03 EDT, Tom
no flags Details

  None (edit)
Description Tom 2013-05-21 02:03:57 EDT
Created attachment 750860 [details]
Icon on desktop with tweak tool

Description of problem:
I do not have managed desktop by file manager, but after Saturday update it showed up. 


Version-Release number of selected component (if applicable):
gnome-shell-3.8.2-2.fc19.x86_64
nautilus-3.8.1-1.fc19.x86_64

I will add additional informations if needed.
Comment 1 Florian Müllner 2013-05-21 03:03:43 EDT
Reassigning to nautilus, which is responsible for desktop icons.
Comment 2 Tom 2013-06-10 06:57:15 EDT
Today after yum update icons disappeared. 
Could be "nemo" responsible for this ?
Comment 3 Tom 2013-06-12 07:51:29 EDT
Update.

Default state is off for "Have file manager handle the desktop" in Gnome Tweak Tool and icons on desktop

Turn on and off "Have file manager handle the desktop", icons disappear. 
Wait for 15 seconds. Waaaaaaait fooooooor it.... 
POP and icons are back and it is not so legendary :-/

How i could provide video of this behaviour ? 

Could it be some my settings corrupted ?
Comment 4 Tom 2013-07-02 06:13:25 EDT
I am pretty sure, it is caused by nemo. 

Close nemo, kill nemo from processes. Icons are not vidible. 
Start nautilus, Icons are not visible. 
Start nemo, Icons are visible on desktop.
Comment 5 Florian Müllner 2013-07-02 11:22:01 EDT
(In reply to Tom from comment #4)
> I am pretty sure, it is caused by nemo. 

It's very much possible that Nemo ignores the setting for showing desktop icons (or uses a different non-GNOME one). Reassigning again ...
Comment 6 Wolfgang Ulbrich 2013-07-02 12:04:05 EDT
I quess you don't use cinnamon, only the better browser :)
In this case i'm pretty shure to help you.

[rave@mother ~]$ cat /usr/share/applications/nemo-autostart.desktop 
[Desktop Entry]
Type=Application
Name=Nemo
Comment=Start Nemo desktop at log in
Exec=nemo -n
OnlyShowIn=GNOME;Unity;
AutostartCondition=GSettings org.nemo.desktop show-desktop-icons
NoDisplay=true

Check gsettings key with
[rave@mother ~]$ gsettings get org.nemo.desktop show-desktop-icons
true
and set to false with
[rave@mother ~]$ gsettings set org.nemo.desktop show-desktop-icons false
Comment 7 leigh scott 2013-07-02 12:52:19 EDT
I have no intention to fix this non issue.

Note You need to log in before you can comment on or make changes to this bug.