Bug 965467 - uucp package should be built with PIE flags
uucp package should be built with PIE flags
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: uucp (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 05:43 EDT by Dhiru Kholia
Modified: 2014-03-24 23:44 EDT (History)
5 users (show)

See Also:
Fixed In Version: uucp-1.07-37.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-24 05:57:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dhiru Kholia 2013-05-21 05:43:56 EDT
Description of problem:

http://fedoraproject.org/wiki/Packaging:Guidelines#PIE says that "you MUST
enable the PIE compiler flags if your package has suid binaries...".

However, currently uucp is not being built with PIE flags. This is a
clear violation of the packaging guidelines.

This issue (in its wider scope) is being discussed at,

https://fedorahosted.org/fesco/ticket/1104

https://lists.fedoraproject.org/pipermail/devel/2013-March/180827.html

Version-Release number of selected component (if applicable):

uucp-1.07-34.fc19.x86_64.rpm

How reproducible:

You can use following programs to check if a package is hardened:

http://people.redhat.com/sgrubb/files/rpm-chksec

OR

https://github.com/kholia/checksec

Steps to Reproduce:

Get scanner.py from https://github.com/kholia/checksec

$ ./scanner.py uucp-1.07-34.fc19.x86_64.rpm
uucp,uucp-1.07-34.fc19.x86_64.rpm,/usr/bin/cu,mode=0106555,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
uucp,uucp-1.07-34.fc19.x86_64.rpm,/usr/bin/uucp,mode=0104555,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
uucp,uucp-1.07-34.fc19.x86_64.rpm,/usr/bin/uulog,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
uucp,uucp-1.07-34.fc19.x86_64.rpm,/usr/bin/uuname,mode=0106555,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
uucp,uucp-1.07-34.fc19.x86_64.rpm,/usr/bin/uupick,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
uucp,uucp-1.07-34.fc19.x86_64.rpm,/usr/bin/uustat,mode=0104555,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
uucp,uucp-1.07-34.fc19.x86_64.rpm,/usr/bin/uux,mode=0104555,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
uucp,uucp-1.07-34.fc19.x86_64.rpm,/usr/sbin/uuchk,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
uucp,uucp-1.07-34.fc19.x86_64.rpm,/usr/sbin/uucico,mode=0106555,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=network-ip
uucp,uucp-1.07-34.fc19.x86_64.rpm,/usr/sbin/uuconv,mode=0100755,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
uucp,uucp-1.07-34.fc19.x86_64.rpm,/usr/sbin/uuxqt,mode=0106555,NX=Enabled,CANARY=Enabled,RELRO=Partial,PIE=Disabled,RPATH=Disabled,RUNPATH=Disabled,FORTIFY=Enabled,CATEGORY=None
Comment 1 Nils Philippsen 2013-05-21 11:09:31 EDT
Bugzilla's had a hickup.

I've submitted updates for Fedora 17 through 19 here:

https://admin.fedoraproject.org/updates/uucp-1.07-37.fc17
https://admin.fedoraproject.org/updates/uucp-1.07-37.fc18
https://admin.fedoraproject.org/updates/uucp-1.07-37.fc19
Comment 2 Nils Philippsen 2014-02-24 05:57:10 EST
Long since fixed.

Note You need to log in before you can comment on or make changes to this bug.