Bug 965699 - Second run of packstack fails on nagios failure
Second run of packstack fails on nagios failure
Status: CLOSED DUPLICATE of bug 950975
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: 3.0
Assigned To: RHOS Maint
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 11:05 EDT by Daniel Paikov
Modified: 2013-07-04 04:02 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 08:59:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nagios_service.cfg (1.26 KB, text/plain)
2013-05-21 11:05 EDT, Daniel Paikov
no flags Details
answer file (7.68 KB, text/plain)
2013-05-21 11:06 EDT, Daniel Paikov
no flags Details

  None (edit)
Description Daniel Paikov 2013-05-21 11:05:34 EDT
Created attachment 751214 [details]
nagios_service.cfg

* Install system using packstack --allinone.
* Run packstack --allinone again.
* Second installation fails for:

notice: /Stage[main]/Nagios_configs/Exec[nagiospasswd]/returns: executed successfully
notice: /Stage[main]/Apache/Service[httpd]: Triggered 'refresh' from 6 events
err: /Stage[main]//Service[nagios]/ensure: change from stopped to running failed: Could not start Service[nagios]: Execution of '/sbin/service nagios start' returned 1:  at /var/tmp/packstack/49ed0325260a42a2a0b062eb470bffaa/manifests/10.35.104.17_nagios.pp:151
notice: /Stage[main]//Service[nagios]: Triggered 'refresh' from 6 events
notice: Finished catalog run in 18.58 seconds

2013-05-21 17:31:12::ERROR::run_setup::906::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 886, in main
    single_step_aio_install(options)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 678, in single_step_aio_install
    single_step_install(options)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 708, in single_step_install
    _main(answerfilepath)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 597, in _main
    runSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 574, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_controller.py", line 77, in runAllSequences
    sequence.run()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_sequences.py", line 153, in run
    step.run()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_sequences.py", line 60, in run
    function()
  File "/usr/lib/python2.6/site-packages/packstack/plugins/puppet_950.py", line 176, in applyPuppetManifest
    waitforpuppet(currently_running)
  File "/usr/lib/python2.6/site-packages/packstack/plugins/puppet_950.py", line 163, in waitforpuppet
    validate_puppet_logfile(log)
  File "/usr/lib/python2.6/site-packages/packstack/modules/ospluginutils.py", line 145, in validate_puppet_logfile
    raise PackStackError(message)
PackStackError: Error during puppet run : err: /Stage[main]//Service[nagios]/ensure: change from stopped to running failed: Could not start Service[nagios]: Execution of '/sbin/service nagios start' returned 1:  at /var/tmp/packstack/49ed0325260a42a2a0b062eb470bffaa/manifests/10.35.104.17_nagios.pp:151


Output of nagios -v /etc/nagios/nagios.cfg:
[root@orange-vdsf ~]# nagios -v /etc/nagios/nagios.cfg

Nagios Core 3.5.0
Copyright (c) 2009-2011 Nagios Core Development Team and Community Contributors
Copyright (c) 1999-2009 Ethan Galstad
Last Modified: 03-15-2013
License: GPL

Website: http://www.nagios.org
Reading configuration data...
   Read main config file okay...
Processing object config file '/etc/nagios/objects/commands.cfg'...
Processing object config file '/etc/nagios/objects/contacts.cfg'...
Processing object config file '/etc/nagios/objects/timeperiods.cfg'...
Processing object config file '/etc/nagios/objects/templates.cfg'...
Processing object config file '/etc/nagios/objects/localhost.cfg'...
Processing object config directory '/etc/nagios/conf.d'...
Processing object config directory '/etc/nagios/resource.d'...
Processing object config file '/etc/nagios/resource.d/nagios_command.cfg'...
Processing object config file '/etc/nagios/resource.d/nagios_service.cfg'...
Processing object config file '/etc/nagios/resource.d/nagios_host.cfg'...
Error: Could not find any host matching '10.35.104.17' (config file '/etc/nagios/resource.d/nagios_service.cfg', starting on line 48)
Error: Could not expand hostgroups and/or hosts specified in service (config file '/etc/nagios/resource.d/nagios_service.cfg', starting on line 48)
   Error processing object config files!


***> One or more problems was encountered while processing the config files...

     Check your configuration file(s) to ensure that they contain valid
     directives and data defintions.  If you are upgrading from a previous
     version of Nagios, you should be aware that some variables/definitions
     may have been removed or modified in this version.  Make sure to read
     the HTML documentation regarding the config files, as well as the
     'Whats New' section to find out what has changed.
Comment 1 Daniel Paikov 2013-05-21 11:06:04 EDT
Created attachment 751215 [details]
answer file
Comment 3 Martin Magr 2013-06-03 08:59:41 EDT

*** This bug has been marked as a duplicate of bug 950975 ***

Note You need to log in before you can comment on or make changes to this bug.