Bug 965750 - ISO deliverable does not have a installer script
ISO deliverable does not have a installer script
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Ivan Necas
Hayk Hovsepyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 12:19 EDT by Og Maciel
Modified: 2013-07-18 17:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:19:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
installer script (3.23 KB, text/x-python)
2013-05-21 12:19 EDT, Og Maciel
no flags Details
README (519 bytes, text/plain)
2013-05-21 12:22 EDT, Og Maciel
no flags Details

  None (edit)
Description Og Maciel 2013-05-21 12:19:26 EDT
Created attachment 751265 [details]
installer script

Description of problem:

The ISO image deliverable does not contain a installer script. Attached you will find what we used for SAM ISOs slightly tweaked to accommodate our new needs. Please include it in the ISO image and make it executable. Also, a README explaining how to install would be a big plus!

Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.7-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.7-1.el6_4.noarch
* candlepin-tomcat6-0.8.7-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-29.noarch
* foreman-postgresql-1.1.10002-29.noarch
* katello-1.4.2-6.el6sat.noarch
* katello-all-1.4.2-6.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-5.el6sat.noarch
* katello-cli-common-1.4.2-5.el6sat.noarch
* katello-common-1.4.2-6.el6sat.noarch
* katello-configure-1.4.3-9.el6sat.noarch
* katello-configure-foreman-1.4.3-9.el6sat.noarch
* katello-foreman-all-1.4.2-6.el6sat.noarch
* katello-glue-candlepin-1.4.2-6.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-6.el6sat.noarch
* katello-glue-pulp-1.4.2-6.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* openldap-devel-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
* ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
* signo-0.0.10-1.el6sat.noarch
* signo-katello-0.0.10-1.el6sat.noarch

How reproducible:


Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Og Maciel 2013-05-21 12:22:59 EDT
Created attachment 751277 [details]
README
Comment 3 Og Maciel 2013-05-28 17:56:08 EDT
This works but can we chmod +x for the installer???
Comment 6 Og Maciel 2013-06-05 11:53:39 EDT
There's been a regression here. The script I included clearly attempts to install "katello-foreman-all" but current script has changed it to "katello-all". Also, the word Satellite 6 has been replaced by Katello.
Comment 7 Og Maciel 2013-06-05 16:24:41 EDT
Also noticed that foreman-proxy-installer is not included.
Comment 8 Ivan Necas 2013-06-12 06:56:47 EDT
Fixed in https://github.com/Katello/katello-misc/pull/10

foreman-proxy-installer should be part of katello-foreman-all at this moment.
Comment 10 Brad Buckingham 2013-06-14 20:08:34 EDT
Mass move to ON_QA
Comment 11 Hayk Hovsepyan 2013-06-17 10:54:17 EDT
Verified in revision:
Katello-Katello-Installation-RegisterRHNClassic-1.1-4.noarch
katello-cli-1.4.2-7.el6sat.noarch
foreman-1.1.10011-1.noarch
openldap-2.4.23-31.el6.x86_64
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-0.8.9-1.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-glue-candlepin-1.4.2-14.el6sat.noarch
katello-all-1.4.2-14.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
signo-0.0.18-1.el6sat.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
katello-cli-common-1.4.2-7.el6sat.noarch
foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
python-ldap-2.3.10-1.el6.x86_64
katello-certs-tools-1.4.2-2.el6sat.noarch
pulp-server-2.1.2-0.3.beta.el6sat.noarch
katello-configure-1.4.3-16.el6sat.noarch
pulp-selinux-2.1.2-0.3.beta.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
foreman-proxy-1.1.10003-1.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-selinux-0.8.9-1.el6_4.noarch
signo-katello-0.0.18-1.el6sat.noarch
katello-glue-elasticsearch-1.4.2-14.el6sat.noarch
katello-glue-pulp-1.4.2-14.el6sat.noarch
katello-1.4.2-14.el6sat.noarch
katello-foreman-all-1.4.2-14.el6sat.noarch
foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
foreman-postgresql-1.1.10011-1.noarch
ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
pulp-rpm-plugins-2.1.2-0.3.beta.el6sat.noarch
foreman-proxy-installer-1.0.1-10.f5ae2cd.el6sat.noarch
candlepin-tomcat6-0.8.9-1.el6_4.noarch
katello-common-1.4.2-14.el6sat.noarch
katello-selinux-1.4.3-3.el6sat.noarch
katello-configure-foreman-1.4.3-16.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
Comment 12 Mike McCune 2013-07-18 17:19:38 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.