Bug 965776 - allow register to Library environment
allow register to Library environment
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Tom McKay
Kedar Bidarkar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 13:07 EDT by Tom McKay
Modified: 2013-07-18 17:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:20:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2013-05-21 13:07:35 EDT
Support registration to Library by both katello and headpin

      * katello *
      https://github.com/Katello/katello/pull/2259/commits e64d1a1
      https://github.com/Katello/katello/pull/2265/commits e82c060
      https://github.com/Katello/katello/pull/2267/commits b68ddec

      * katello-cli *
      https://github.com/Katello/katello-cli/pull/26/commits 25c6fbc

Headpin no longer supports any environments other than Library. Both headpin and katello allow full use of Library for system registration, distributor creation, etc.
Comment 1 Tom McKay 2013-05-21 13:11:36 EDT
 https://github.com/Katello/katello/pull/2337/commits 10f68fe

Fixes system and distributor UI, taking Library env into account.
Comment 2 Brad Buckingham 2013-05-21 15:24:06 EDT
The following includes changes to allow library to be 'selected' on system and distributor edit:

pull request:
https://github.com/Katello/katello/pull/2345

commit:
c2b2b66cbf30fa98f6cbc4330045b5f0c8cf40fd
Comment 3 Brad Buckingham 2013-05-22 06:51:29 EDT
PR from comment #2 has been merged.  Moving BZ to POST.
Comment 6 Sam Kottler 2013-05-23 19:41:33 EDT
Moving to ON_QA for drop 2.
Comment 7 sthirugn@redhat.com 2013-06-03 16:08:49 EDT
Tested Satellite 6 version below and is working fine.

Test 1:
# subscription-manager register --username $user --password $pass --org ACME_Corporation --environment Library --autosubscribe --force
The system with UUID c4850e25-74f5-4267-8990-6e351d701451 has been unregistered

Test 2:
I am able to select Library in new Distributor creation

Test 3:
I am able to select Library in System creation

Sat 6 Version Tested:
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-40.noarch
* foreman-postgresql-1.1.10002-40.noarch
* katello-1.4.2-7.el6sat.noarch
* katello-all-1.4.2-7.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-6.el6sat.noarch
* katello-cli-common-1.4.2-6.el6sat.noarch
* katello-common-1.4.2-7.el6sat.noarch
* katello-configure-1.4.3-10.el6sat.noarch
* katello-configure-foreman-1.4.3-10.el6sat.noarch
* katello-foreman-all-1.4.2-7.el6sat.noarch
* katello-glue-candlepin-1.4.2-7.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-7.el6sat.noarch
* katello-glue-pulp-1.4.2-7.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch


*******************************************************************************

Also in headpin nightly mode, verified the following:
1. Able to subscribe without giving environment attribute in subscription-manager:
# subscription-manager register --username $user --password $pass --org 1org --environment Library --autosubscribe --force
Error: Server does not support environments.
# subscription-manager register --username $user --password $pass --org 1org --autosubscribe --force
The system has been registered with id: d0f251b7-d482-4cc2-8e25-a6f1bb70eb53

2. Able to select Library environment in Distributor creation

3. The new Organization creator now does not show enviornment selector

Headpin nightly version tested:
* candlepin-0.8.12-1.el6.noarch
* candlepin-cert-consumer-hp-dl585-02.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-tomcat6-0.8.12-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.71.2a2d883.el6.noarch
* katello-cli-common-1.4.2-1.git.71.2a2d883.el6.noarch
* katello-common-1.4.2-1.git.527.9ece6de.el6.noarch
* katello-configure-1.4.3-1.git.51.c5aa3be.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.527.9ece6de.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.527.9ece6de.el6.noarch
* katello-headpin-1.4.2-1.git.527.9ece6de.el6.noarch
* katello-headpin-all-1.4.2-1.git.527.9ece6de.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-3.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
* thumbslug-0.0.27-1.el6.noarch
* thumbslug-selinux-0.0.27-1.el6.noarch
********************************************************************************
Comment 8 Mike McCune 2013-07-18 17:20:36 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.