Bug 965825 - Cluster Service Sub Tab not displaying hosts
Cluster Service Sub Tab not displaying hosts
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kanagaraj
Dustin Tsang
:
: 973602 (view as bug list)
Depends On: 927648 982479
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 15:54 EDT by Dustin Tsang
Modified: 2016-04-18 06:06 EDT (History)
10 users (show)

See Also:
Fixed In Version: bb6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (127.37 KB, image/png)
2013-05-21 15:54 EDT, Dustin Tsang
no flags Details
screenshot with gluster status (285.89 KB, image/png)
2013-05-22 07:36 EDT, Dustin Tsang
no flags Details
engine log (163.08 KB, text/x-log)
2013-05-30 08:32 EDT, Dustin Tsang
no flags Details
server log (21.17 KB, text/x-log)
2013-05-30 08:33 EDT, Dustin Tsang
no flags Details
vdsm log (231.09 KB, text/x-log)
2013-06-04 12:13 EDT, Dustin Tsang
no flags Details

  None (edit)
Description Dustin Tsang 2013-05-21 15:54:16 EDT
Created attachment 751363 [details]
screenshot

Description of problem:

Cluster Service Sub Tab shows not hosts.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. create a cluster with 2 nodes
2. add a distributed volume using o and start the volume
3. navigate to the cluster main tab
4. click on the services sub tab
5. in the sub tab, in the host dropdown, select the first host and click filter.

Actual results:

no services displayed


Expected results:

services should be displayed such as samba, gluster, etc.

Additional info:
Comment 1 Dustin Tsang 2013-05-21 15:58:25 EDT
Versions: rhsc-2.1.0-0.bb1.el6rhs.noarch and RHS-2.1-20130515.n.0-RHS-x86_64-DVD1.iso
Comment 3 Kanagaraj 2013-05-22 06:37:00 EDT
Dustin,

We are currently capturing the details of NFS and SHD(Self-heal daemon) services and show them on the ui.

NFS process will be running in the nodes only if a volume of the cluster supports nfs(nfs.disable=off). Also SHD will be running only if you have a Replicate volume.

Can you please provide the output of the following command in one of the storage nodes.

gluster volume status <volname>
Comment 4 Dustin Tsang 2013-05-22 07:32:16 EDT
I used a replicate volume with nfs.disabled=off but still can not get any information to display on the services sub tab.

I'm attaching a screenshot with output from from 'gluster volume status' and screenshot of from rhsc.
Comment 5 Dustin Tsang 2013-05-22 07:36:31 EDT
Created attachment 751666 [details]
screenshot with gluster status
Comment 6 Kanagaraj 2013-05-22 08:10:22 EDT
Looks like there is no problem with the configuration.

Can you please attach the engine.log and vdsm.log files?
Comment 7 Dustin Tsang 2013-05-30 08:32:40 EDT
Created attachment 754820 [details]
engine log

engine log attached
Comment 8 Dustin Tsang 2013-05-30 08:33:21 EDT
Created attachment 754821 [details]
server log

server.log attached
Comment 9 Kanagaraj 2013-06-04 08:21:18 EDT
Dustin,

Can you please attach the vdsm.log files from the storage nodes as well?
Comment 10 Dustin Tsang 2013-06-04 12:13:26 EDT
Created attachment 756872 [details]
vdsm log

sorry about that...vdsm log attached.
Comment 11 Sahina Bose 2013-06-11 05:18:23 EDT
Related to glusterfs bug where the server id is shown instead of ip in the volume status command. 
Since you were filtering by host, there are no services shown in the list
Comment 12 Sahina Bose 2013-06-13 07:46:09 EDT
*** Bug 973602 has been marked as a duplicate of this bug. ***
Comment 13 Sahina Bose 2013-07-10 09:51:21 EDT
Moving to Modified as fix will be available in next RHS 2.1 respin
Comment 14 Sahina Bose 2013-07-17 05:45:42 EDT
Fixed in bb6
Comment 16 Scott Haines 2013-09-23 18:25:42 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.