Bug 965851 - When changing from cirrus->qxl, offer to change from vnc->spice
When changing from cirrus->qxl, offer to change from vnc->spice
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 16:48 EDT by Bill Nottingham
Modified: 2014-03-16 23:33 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 18:57:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2013-05-21 16:48:22 EDT
Description of problem:

For example, it lets you leave the connection as VNC if you change the display adapter from Cirrus to Spice. That doesn't work well.

Version-Release number of selected component (if applicable):

virt-manager-0.10.0-0.2.gitb68faac8.fc19.noarch
Comment 1 Cole Robinson 2013-05-22 11:29:57 EDT
I can't quite parse that, do you mean change from cirrus->qxl ?

VNC _should_ work with QXL, if it doesn't that's a qemu bug. In fact this combo can be useful for testing: spice+qxl is responsible for many qemu crashes, reproducing (or not) with VNC+qxl or spice+cirrus can be a useful datapoint.
Comment 2 Bill Nottingham 2013-05-22 14:05:06 EDT
Correct, I changed from cirrus to qxl, and it didn't work. (garbage on screen), so I assumed it wasn't expected to.
Comment 3 Cole Robinson 2013-10-02 18:57:17 EDT
I went the opposite direction upstream: ripped out the 'do you want to add/remove spicevmc' when changing vnc->spice

virt-manager and virt-install will use spice + qxl + spicevmc as default everywhere unless the user expressly overrides it, that should be sufficient to put the right defaults in place. qxl and spice _should_ work but of course it's not that well tested so issues might arise, but we should deal with them if they exist since it's a useful debugging scenario

Note You need to log in before you can comment on or make changes to this bug.