Bug 965891 - QA:Testcase JBoss AS Install and run - jboss-as.service does not start.
QA:Testcase JBoss AS Install and run - jboss-as.service does not start.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: jboss-as (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Goldmann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 18:59 EDT by Flóki Pálsson
Modified: 2013-06-04 23:18 EDT (History)
2 users (show)

See Also:
Fixed In Version: jboss-as-7.1.1-19.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 23:18:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Flóki Pálsson 2013-05-21 18:59:36 EDT
Description of problem:
jboss-as.service does not start.




Version-Release number of selected component (if applicable):
jboss-as-7.1.1-16.fc19.noarch


How reproducible:
First try. To install.

Steps to Reproduce:
1. yum install jboss-as --enablerepo=updates-testing
2. Step #2 starts the service, check with ps ax, try curl http://localhost:8080
3.

Actual results:
No connection



Expected results:
connection 

Additional info:

$ systemctl status jboss-as.service
jboss-as.service - The JBoss Application Server
   Loaded: loaded (/usr/lib/systemd/system/jboss-as.service; disabled)
   Active: failed (Result: exit-code) since þri 2013-05-21 22:45:57 GMT; 7min ago
  Process: 11038 ExecStart=/usr/share/jboss-as/bin/standalone.sh -c $JBOSS_CONFIG -b $JBOSS_BIND (code=exited, status=1/FAILURE)

See:
http://fedoraproject.org/wiki/QA:Testcase_JBoss_AS_Install_and_run
Comment 1 Marek Goldmann 2013-05-22 03:54:11 EDT
Thanks, I'll look at this today!
Comment 2 Marek Goldmann 2013-05-22 04:40:45 EDT
It seems that the problem exists because of some broken links. These were introduced by the jar location change from the upstream projects, a simple rebuild of the jboss-as package should help. I'm doing it right now to confirm this.
Comment 3 Fedora Update System 2013-05-24 02:26:01 EDT
jboss-as-7.1.1-19.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/jboss-as-7.1.1-19.fc19
Comment 4 Fedora Update System 2013-05-24 15:48:05 EDT
Package jboss-as-7.1.1-19.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing jboss-as-7.1.1-19.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9086/jboss-as-7.1.1-19.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-06-04 23:18:38 EDT
jboss-as-7.1.1-19.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.