Bug 965899 - Composite content views are published with a path that mismatches what pulp has
Composite content views are published with a path that mismatches what pulp has
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 20:07 EDT by Og Maciel
Modified: 2013-07-18 17:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:23:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Og Maciel 2013-05-21 20:07:59 EDT
Description of problem:

Seems that composite content views that are published are exposed using a different path than what pulp (i.e. the file system) has. I created ContentView1 and added RHEL + custom repository (published via http) to it; published it. Created ContentView2 and added another custom repository (also http published) to it; added a packages filter and published. Then created a composite ContentView3 made out of ContentView1 and ContentView2. ContentView3 was then published and then promoted to environment Library+1 and added it to an activationkey.

I then registered and subscribed 2 clients using the activationkey and tried to consume content but yum complained with 404 errors.

yum repolist shows https://hp-bl460cg7-01.rhts.eng.bos.redhat.com/pulp/repos/c36e6dde-934f-4e97-b56d-4
b42eeb0d192/Dev_Env/PublishedCCVD/custom/Chrome/google-chrome-64bit/repodata/repomd.xml

but pulp has /var/lib/pulp/published/http/repos/c36e6dde-934f-4e97-b56d-4b42eeb0d192/Dev_Env/PublishedCCVD/PublishedChrome64/custom/Chrome/google-chrome-64bit/repodata/repomd.xml

The difference here is that pulp has the composite view (PublishedCCVD) as the parent of the secondary "child" content view (PublishedChrome64).


Version-Release number of selected component (if applicable):

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.7-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.7-1.el6_4.noarch
* candlepin-tomcat6-0.8.7-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-29.noarch
* foreman-postgresql-1.1.10002-29.noarch
* katello-1.4.2-6.el6sat.noarch
* katello-all-1.4.2-6.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-5.el6sat.noarch
* katello-cli-common-1.4.2-5.el6sat.noarch
* katello-common-1.4.2-6.el6sat.noarch
* katello-configure-1.4.3-9.el6sat.noarch
* katello-configure-foreman-1.4.3-9.el6sat.noarch
* katello-foreman-all-1.4.2-6.el6sat.noarch
* katello-glue-candlepin-1.4.2-6.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-6.el6sat.noarch
* katello-glue-pulp-1.4.2-6.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* openldap-devel-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
* ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
* signo-0.0.10-1.el6sat.noarch
* signo-katello-0.0.10-1.el6sat.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Og Maciel 2013-05-21 20:11:33 EDT
# rpm -q subscription-manager
subscription-manager-0.99.19.4-1.el6_3.x86_64

# yum repolist
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.

Please use yum-config-manager to configure which software
repositories are used with Red Hat Subscription Management.

https://SERVER/pulp/repos/c36e6dde-934f-4e97-b56d-4b42eeb0d192/Dev_Env/PublishedCCVD/custom/Chrome/google-chrome-64bit/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
repo id                                                             repo name                                  status
c36e6dde-934f-4e97-b56d-4b42eeb0d192_Chrome_google-chrome-64bit     google-chrome-64bit                        0
c36e6dde-934f-4e97-b56d-4b42eeb0d192_Satellite6Tools_katello-agent  katello-agent                              0
rhel-6-server-rpms                                                  Red Hat Enterprise Linux 6 Server (RPMs)   0
repolist: 0

# subscription-manager environments --org c36e6dde-934f-4e97-b56d-4b42eeb0d192
Username: admin
Password: 
+-------------------------------------------+
          Environments
+-------------------------------------------+
Name:                         GA_Env                   
Description:                  None                     

Name:                         QE_Env                   
Description:                  None                     

Name:                         Dev_Env                  
Description:                  None                     

Name:                         Dev_Env/Published1       
Description:                  Contains RHEL and Katello Agent bits for x86_64.

Name:                         Library/Published1       
Description:                  Contains RHEL and Katello Agent bits for x86_64.

Name:                         Dev_Env/PublishedCCVD    
Description:                                           

Name:                         Library/PublishedCCVD    
Description:                                           

Name:                         Dev_Env/PublishedChrome64
Description:                                           

Name:                         Library/PublishedChrome64
Description:                                           

# yum install katello-agent
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.

Please use yum-config-manager to configure which software
repositories are used with Red Hat Subscription Management.

https://SERVER/pulp/repos/c36e6dde-934f-4e97-b56d-4b42eeb0d192/Dev_Env/PublishedCCVD/custom/Chrome/google-chrome-64bit/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: c36e6dde-934f-4e97-b56d-4b42eeb0d192_Chrome_google-chrome-64bit. Please verify its path and try again
Comment 2 Brad Buckingham 2013-05-23 11:49:41 EDT
https://github.com/Katello/katello/pull/2361
Comment 4 Sam Kottler 2013-05-23 19:41:02 EDT
Moving to ON_QA for drop 2.
Comment 5 Og Maciel 2013-05-31 17:07:20 EDT
# yum repolist
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.

Please use yum-config-manager to configure which software
repositories are used with Red Hat Subscription Management.

SimpleOrg_Agent_katello-agent                                                                 | 3.3 kB     00:00     
SimpleOrg_Chrome_google-chrome-64bit                                                          | 2.9 kB     00:00     
google-chrome                                                                                 |  951 B     00:00     
google-chrome/primary                                                                         | 1.9 kB     00:00     
google-chrome                                                                                                    3/3
rhel-6-server-rpms                                                                            | 3.8 kB     00:00     
repo id                                              repo name                                                 status
SimpleOrg_Agent_katello-agent                        katello-agent                                                 11
SimpleOrg_Chrome_google-chrome-64bit                 google-chrome-64bit                                            1
google-chrome                                        google-chrome                                                  3
rhel-6-server-rpms                                   Red Hat Enterprise Linux 6 Server (RPMs)                  10,555
repolist: 10,570

# subscription-manager environments --org SimpleOrg --user admin --password admin
+-------------------------------------------+
          Environments
+-------------------------------------------+
Name:                 	GA_Env                   
Description:          	None                     

Name:                 	QA_Env                   
Description:          	None                     

Name:                 	Dev_Env                  
Description:          	None                     

Name:                 	Dev_Env/PublishedAgent   
Description:          	Contains the katello-agent and friends.

Name:                 	Library/PublishedAgent   
Description:          	Contains the katello-agent and friends.

Name:                 	Dev_Env/PublishedChrome  
Description:          	Contains Google Chrome stable version only.

Name:                 	Library/PublishedChrome  
Description:          	Contains Google Chrome stable version only.

Name:                 	Dev_Env/PublishedComposite
Description:          	Contains RHEL, Google Chrome and the katello-agent.

Name:                 	Library/PublishedComposite
Description:          	Contains RHEL, Google Chrome and the katello-agent.

Name:                 	Dev_Env/PublishedRHEL    
Description:          	Contains Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server

Name:                 	Library/PublishedRHEL    
Description:          	Contains Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server
Comment 6 Og Maciel 2013-05-31 17:08:50 EDT
Verified:
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-cert-consumer-qeblade35.rhq.lab.eng.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-44.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-postgresql-1.1.10002-44.noarch
* foreman-proxy-1.1.10002-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-8.el6sat.noarch
* katello-all-1.4.2-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-6.el6sat.noarch
* katello-cli-common-1.4.2-6.el6sat.noarch
* katello-common-1.4.2-8.el6sat.noarch
* katello-configure-1.4.3-12.el6sat.noarch
* katello-configure-foreman-1.4.3-12.el6sat.noarch
* katello-foreman-all-1.4.2-8.el6sat.noarch
* katello-glue-candlepin-1.4.2-8.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-8.el6sat.noarch
* katello-glue-pulp-1.4.2-8.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
* ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
* signo-0.0.15-1.el6sat.noarch
* signo-katello-0.0.15-1.el6sat.noarch
Comment 7 Mike McCune 2013-07-18 17:23:29 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.