Bug 965911 - Add a trigger to release comment width limit
Add a trigger to release comment width limit
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: User Interface (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
:
: 605715 966131 1025728 (view as bug list)
Depends On:
Blocks: 1318165
  Show dependency treegraph
 
Reported: 2013-05-21 22:29 EDT by Monson Shao
Modified: 2016-03-16 04:20 EDT (History)
7 users (show)

See Also:
Fixed In Version: 4.4.0009
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1318165 (view as bug list)
Environment:
Last Closed: 2013-10-03 20:46:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Monson Shao 2013-05-21 22:29:34 EDT
Description of problem:

Now comment width is limited by

.bz_comment_text {
     width: 50em;
}

It will cause autowrap when comments exceed this and it is good for discussion. But for codes or calltrace, autowrap will make things hard to understand, we want them showed as original if possible.

Version-Release number of selected component (if applicable):
4.4

Actual results:
all comments are autowrap.

Expected results:
some way to disable autowrap

Additional info:
Comment 1 Simon Green 2013-05-26 19:39:44 EDT
*** Bug 966131 has been marked as a duplicate of this bug. ***
Comment 2 Simon Green 2013-05-26 19:44:22 EDT
We will add two things:

1) A preference on whether the default should be to wrap or not. The default will be to wrap. Since this would be what the majority of users would want.

2) A toggle option at the top of the comments (under 'Expand All Comments') so that this can be changed specifically for a single page load.

  -- simon
Comment 3 Simon Green 2013-07-23 19:59:40 EDT
*** Bug 605715 has been marked as a duplicate of this bug. ***
Comment 5 Simon Green 2013-10-03 20:46:38 EDT
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

  -- simon
Comment 6 Simon Green 2013-11-26 00:30:55 EST
*** Bug 1025728 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.