Bug 965977 - Unauthenticated request made when using wrong credentials
Unauthenticated request made when using wrong credentials
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Marek Hulan
Hayk Hovsepyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 04:23 EDT by Marek Hulan
Modified: 2013-07-18 17:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:19:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Hulan 2013-05-22 04:23:38 EDT
Description of problem:

When user enters wrong credentials, login screen still tries to fetch allowed organizations. If you have Signo enabled, request redirects to Signo and load it's CSS which repaints the screen. We should make all further requests only if login is sucessful. Also an error notification is not displayed.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. go to login screen
2. enter wrong credentials
3. submit

Actual results:

A request to load allowed organizations is made resulting in unauthenticated error.

Expected results:

No other request are made until user really logs in.

Additional info:

Patch awaits review before merge https://github.com/Katello/katello/pull/2348
Comment 2 Brad Buckingham 2013-05-29 13:39:07 EDT
Since the fix is available and it was initially requested for sat-6.0.1 and QA acked, going to realign it to sat-6.0.1.
Comment 4 Hayk Hovsepyan 2013-06-04 07:35:15 EDT
Verified in revision:
ruby193-rubygem-foreman-katello-engine-0.0.8-4.el6sat.noarch
katello-configure-1.4.3-12.el6sat.noarch
katello-common-1.4.2-8.el6sat.noarch
katello-glue-elasticsearch-1.4.2-8.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-agent-1.4.2-4.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-common-1.4.2-6.el6sat.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
signo-katello-0.0.15-1.el6sat.noarch
katello-glue-candlepin-1.4.2-8.el6sat.noarch
katello-selinux-1.4.3-3.el6sat.noarch
katello-1.4.2-8.el6sat.noarch
katello-configure-foreman-1.4.3-12.el6sat.noarch
katello-foreman-all-1.4.2-8.el6sat.noarch
katello-cli-1.4.2-6.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-2.el6_4.noarch
katello-glue-pulp-1.4.2-8.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.3-4.el6sat.noarch
katello-all-1.4.2-8.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch

Now it shows error message and does not go to any page.
Comment 5 Mike McCune 2013-07-18 17:19:06 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.