Bug 965991 - src qemu core dump after migrate_cancel
src qemu core dump after migrate_cancel
Status: CLOSED DUPLICATE of bug 1053699
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
medium Severity high
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 05:01 EDT by Xiaoqing Wei
Modified: 2014-02-11 12:10 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-11 12:10:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
src_qemu_core_dump_after_mig_cancel.txt (18.46 KB, text/plain)
2013-05-22 05:01 EDT, Xiaoqing Wei
no flags Details
core.tar.xz part 1 (60.00 MB, application/octet-stream)
2013-05-22 05:33 EDT, Xiaoqing Wei
no flags Details
core.tar.xz part 2 (46.18 MB, application/octet-stream)
2013-05-22 05:42 EDT, Xiaoqing Wei
no flags Details

  None (edit)
Description Xiaoqing Wei 2013-05-22 05:01:14 EDT
Created attachment 751580 [details]
src_qemu_core_dump_after_mig_cancel.txt

Description of problem:

src qemu core dump after migrate_cancel

Version-Release number of selected component (if applicable):
qemu-kvm-1.4.0-4.el7.x86_64
kernel-3.9.0-0.55.el7.x86_64
guest:
win2012
virtio-win-prewhql-62

How reproducible:
1/4

Steps to Reproduce:
1. boot vms, append '-incoming tcp:0:5200' to dest vm
/home/staf-kvm-devel/autotest-devel/client/tests/virt/qemu/qemu \
    -S \
    -name 'vm1' \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20130522-153958-fJbbShBR,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20130522-153958-fJbbShBR,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20130522-153958-fJbbShBR,path=/tmp/seabios-20130522-153958-fJbbShBR,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20130522-153958-fJbbShBR,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,addr=0x5 \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/images/win2012-64-virtio.qcow2',if=none,id=virtio-scsi-id0,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device scsi-hd,drive=virtio-scsi-id0 \
    -device virtio-net-pci,netdev=id6AaEGs,mac=9a:bf:c0:c1:c2:c3,bus=pci.0,addr=0x3,id='idf0I07Q' \
    -netdev tap,id=id6AaEGs,vhost=on,fd=22 \
    -m 2048 \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2 \
    -cpu 'Opteron_G3' \
    -M pc \
    -drive file='/home/staf-kvm-devel/autotest-devel/client/tests/virt/shared/data/isos/windows/winutils.iso',if=none,id=virtio-scsi-id1,media=cdrom,snapshot=off,readonly=on,format=raw \
    -device scsi-cd,drive=virtio-scsi-id1 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -vnc :0 \
    -vga std \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off  \
    -enable-kvm


2. type migrate_cancel in src monitor
3.

Actual results:
src core dump

Expected results:
src qemu work well, not core dump

Additional info:
(gdb) bt
#0  _wordcopy_fwd_dest_aligned (dstp=<optimized out>, srcp=<optimized out>, len=561668) at wordcopy.c:201
#1  0x00007f2220dbfff7 in __memmove_sse2 (dest=0x7f217e4fe010, src=<optimized out>, len=27996983) at ../string/memmove.c:78
#2  0x00007f22253705f3 in memmove (__len=<optimized out>, __src=<optimized out>, __dest=<optimized out>) at /usr/include/bits/string3.h:57
#3  buffered_flush (s=s@entry=0x7f22258bb4a0 <current_migration.19549>) at migration.c:538
#4  0x00007f2225371152 in buffered_file_thread (opaque=0x7f22258bb4a0 <current_migration.19549>) at migration.c:747
#5  0x00007f222347cc53 in start_thread (arg=0x7f2186c01700) at pthread_create.c:308
#6  0x00007f2220e2c0dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113
(gdb)
Comment 2 Xiaoqing Wei 2013-05-22 05:33:54 EDT
Created attachment 751617 [details]
core.tar.xz part 1
Comment 3 Xiaoqing Wei 2013-05-22 05:42:12 EDT
Created attachment 751618 [details]
core.tar.xz part 2
Comment 6 Juan Quintela 2014-02-11 12:10:29 EST
This bug is a duplicate of 1053699  And there is already a patch for it.1053699

*** This bug has been marked as a duplicate of bug 1053699 ***

Note You need to log in before you can comment on or make changes to this bug.