Bug 965998 - Command org.ovirt.engine.core.bll.TryBackToSnapshotCommand throw exception: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0 When the user click snapshot preview mode.
Command org.ovirt.engine.core.bll.TryBackToSnapshotCommand throw exception: j...
Status: CLOSED DUPLICATE of bug 854185
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity unspecified
: ---
: 3.3.0
Assigned To: Maor
Haim
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 05:20 EDT by Yoshinori Takahashi
Modified: 2016-02-10 15:21 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-16 07:58:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Allon Mureinik 2013-06-02 04:06:33 EDT
Maor, I have a feeling we already saw and fixed this in 3.2 - please check (and solve if not).
Comment 2 Maor 2013-06-16 07:58:22 EDT
This bug is a duplicate of https://bugzilla.redhat.com/854185.

We can see that the same exception occurs in the current bug [1] and in BZ854185 [2]:

[1]
2013-05-16 17:18:57,003 ERROR [org.ovirt.engine.core.bll.TryBackToSnapshotCommand] (ajp-/127.0.0.1:8702-13) [696ff4a4] Command org.ovirt.engine.core.bll.TryBackToSnapshotCommand throw exception: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
	at java.util.ArrayList.rangeCheck(ArrayList.java:604) [rt.jar:1.7.0_09-icedtea]
	at java.util.ArrayList.get(ArrayList.java:382) [rt.jar:1.7.0_09-icedtea]
	at org.ovirt.engine.core.bll.BaseImagesCommand.findImageForSameDrive(BaseImagesCommand.java:218) [engine-bll.jar:]

[2]
2012-09-04 15:18:28,049 ERROR [org.ovirt.engine.core.bll.TryBackToSnapshotCommand] (ajp-/127.0.0.1:8009-13) [6bd0a119] Command org.ovirt.engine.core.bll.TryBackToSnapshotCommand throw exception: java.lang.IndexOutOfBoundsException:
....
org.ovirt.engine.core.bll.BaseImagesCommand.findImageForSameDrive(BaseImagesCommand.java:218) [engine-bll.jar:]

Also tried to reproduce it on the upstream and no exception was thrown.

*** This bug has been marked as a duplicate of bug 854185 ***

Note You need to log in before you can comment on or make changes to this bug.