Bug 966033 - Can't insert ISO which is under "/root/" to guest
Can't insert ISO which is under "/root/" to guest
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Kletzander
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 06:13 EDT by CongDong
Modified: 2014-06-17 20:00 EDT (History)
7 users (show)

See Also:
Fixed In Version: virt-manager-0.10.0-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:31:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CongDong 2013-05-22 06:13:49 EDT
Description of problem:
Can't insert an ISO to guest

Version-Release number of selected component (if applicable):
virt-manager-0.10.0-0.2.gitb68faac8.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Make sure have a good guest and an ISO file which is under "/root/".
2. "Force off" the guest
3. Open the "Details" tab of the guest.
4. "Add hardware" -> "Storage" -> "Select managed or other existing storage"
5. Choose the ISO file and change the “Device type” to "IDE CDROM"
6. "Finish"

Actual results:
  Can insert the ISO sucessfully.

Expected results:
An error cames out after step6:
  Uncaught error validating hardware input: argument of type 'bool' is not terable
  Traceback (most recent call last):
    File "/usr/share/virt-manager/virtManager/addhardware.py", line 881, in finish
      if self.validate(notebook.get_current_page()) is False:
    File "/usr/share/virt-manager/virtManager/addhardware.py", line 1209, in alidate
      return self.validate_page_storage()
    File "/usr/share/virt-manager/virtManager/addhardware.py", line 1333, in validate_page_storage
      self.conn, disk.path)
    File "/usr/share/virt-manager/virtManager/uihelpers.py", line 949, in check_path_search_for_qemu
      if p in skip_paths:
  TypeError: argument of type 'bool' is not iterable

Additional info:
Comment 2 Martin Kletzander 2013-05-22 08:01:04 EDT
Probably the main reason for this was fixed in commit bde99432, so I'm moving to POST, feel free to reassing if it's not fixed for you in next version.

commit bde9943221c3d78388fb554cc5a2838b05aaa7de
Author: Cole Robinson <crobinso@redhat.com>
Date:   Wed May 15 15:35:55 2013 -0400

    gsettings: Fix default for perms-fix-ignore (bz 962569)
Comment 4 CongDong 2013-08-14 05:43:51 EDT
Sorry, I mixed the "Actual results" the "Expected results" .
Correct here:

Expected results:
  Can insert the ISO sucessfully.

Actual results:
An error cames out after step6:
  Uncaught error validating hardware input: argument of type 'bool' is not terable
  Traceback (most recent call last):
    File "/usr/share/virt-manager/virtManager/addhardware.py", line 881, in finish
      if self.validate(notebook.get_current_page()) is False:
    File "/usr/share/virt-manager/virtManager/addhardware.py", line 1209, in alidate
      return self.validate_page_storage()
    File "/usr/share/virt-manager/virtManager/addhardware.py", line 1333, in validate_page_storage
      self.conn, disk.path)
    File "/usr/share/virt-manager/virtManager/uihelpers.py", line 949, in check_path_search_for_qemu
      if p in skip_paths:
  TypeError: argument of type 'bool' is not iterable


But virt-manager-0.10.0-0.2.gitb68faac8.el7.noarch is deleted in brewweb, I can't get it and can't reproduce with other version.
Comment 8 CongDong 2013-08-18 21:24:30 EDT
Ok, as the result from comment 4 and comment 6, set VERIFIED.
Comment 9 Ludek Smid 2014-06-13 09:31:16 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.