Bug 966101 - tasks list lists prints all importer details for update_importer task
tasks list lists prints all importer details for update_importer task
Status: CLOSED DUPLICATE of bug 1073999
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
2.1.1
Unspecified Unspecified
low Severity low
: ---
: 2.5.0
Assigned To: pulp-bugs
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 09:13 EDT by Justin Sherrill
Modified: 2014-09-02 21:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-05 14:08:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2013-05-22 09:13:00 EDT
Description of problem:

After issuing an importer update with a feed cert, ca, and key specified running 'pulp-admin tasks list'  prints all of the ca certs and keys.

Example:

Operations:  update_importer
Resources:   ACME_Corporation-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise
             _Linux_6_Server_RPMs_x86_64_6Server (repository), yum_importer
             (repository_importer)
State:       Successful
Start Time:  2013-05-22T13:03:22Z
Finish Time: 2013-05-22T13:03:22Z
Result:      
  Config:           
    Feed URL:        https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x
                     86_64/os
    SSL CA Cert:     -----BEGIN CERTIFICATE-----
                     MIIG/TCCBOWgAwIBAgIBNzANBgkqhkiG9w0BAQUFADCBsTELMAkGA1UEBhM
                     CVVMx
                     FzAVBgNVBAgMDk5vcnRoIENhcm9saW5hMRYwFAYDVQQKDA1SZWQgSGF0LCB
                     JbmMu
                     MRgwFgYDVQQLDA9SZWQgSGF0IE5ldHdvcmsxMTAvBgNVBAMMKFJlZCBIYXQ
                     gRW50
                     aXRsZW1lbnQgT3BlcmF0aW9ucyBBdXRob3JpdHkxJDAiBgkqhkiG9w0BCQE
                     WFWNh
                     LXN1cHBvcnRAcmVkaGF0LmNvbTAeFw0xMDEwMDQxMzI3NDhaFw0zMDA5Mjk
                     xMzI3
                     NDhaMIGuMQswCQYDVQQGEwJVUzEXMBUGA1UECAwOTm9ydGggQ2Fyb2xpbmE
                     xFjAU
                     BgNVBAoMDVJlZCBIYXQsIEluYy4xGDAWBgNVBAsMD1JlZCBIYXQgTmV0d29
                     yazEu
                     MCwGA1UEAwwlUmVkIEhhdCBFbnRpdGxlbWVudCBQcm9kdWN0IEF1dGhvcml
                     0eTEk
                     MCIGCSqGSIb3DQEJARYVY2Etc3VwcG9ydEByZWRoYXQuY29tMIICIjANBgk
                     qhkiG
                     9w0BAQEFAAOCAg8AMIICCgKCAgEA2QurMeAVnCHVsuZNQzciWMdpd4LAVk2
                     eGugN
                     0cxmBpzoVI8lIsJOmJkpOAuFOQMX9CBr8RuQyg4r1/OH/rfhm6FgGIw8TGK
                     ZoWC/
                     1B9teZqTiM85k6/1GRNxdk6dUK77HVO0PMIKtNBHRxIsXcRzJ1q+u5WPBes
<SNIP LOTS MORE TEXT>



Version-Release number of selected component (if applicable):
2.1.1

How reproducible:
Always

Steps to Reproduce:
1.  Create a repo with a yum importer
2.  Issue an importer update, updating the ssl cert/key/ca
3.  run   'pulp-admin tasks list'

Actual results:
Very long, difficult to read result

Expected results:
Short simple result.
Comment 1 Jeremy Cline 2014-08-05 14:08:43 EDT

*** This bug has been marked as a duplicate of bug 1073999 ***

Note You need to log in before you can comment on or make changes to this bug.