Bug 966130 - Error: samba-libs-4.0.6-1.fc20 Requires: libdfs_server_ad.so
Error: samba-libs-4.0.6-1.fc20 Requires: libdfs_server_ad.so
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
: 966436 966624 (view as bug list)
Depends On:
Blocks: 966148
  Show dependency treegraph
 
Reported: 2013-05-22 10:29 EDT by Rex Dieter
Modified: 2013-06-04 17:02 EDT (History)
8 users (show)

See Also:
Fixed In Version: samba-4.0.6-2.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-27 22:21:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2013-05-22 10:29:34 EDT
Rawhide koji builds are failing today with:

DEBUG util.py:264:  Error: Package: 2:samba-libs-4.0.6-1.fc20.i686 (build)
DEBUG util.py:264:             Requires: libdfs_server_ad.so
DEBUG util.py:264:  Error: Package: 2:samba-libs-4.0.6-1.fc20.i686 (build)
DEBUG util.py:264:             Requires: libdfs_server_ad.so(SAMBA_4.0.6)
DEBUG util.py:264:   You could try using --skip-broken to work around the problem
DEBUG util.py:264:   You could try running: rpm -Va --nofiles --nodigest

May be related to recent changes in rpm with regard to library dependency generation.
Comment 2 Andreas Schneider 2013-05-22 11:39:44 EDT
I tried the AD build to be up to date with file names but forgot to set it back. Sorry for that, new build on the way ...
Comment 3 Fedora Update System 2013-05-22 18:37:50 EDT
Package samba-4.0.6-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing samba-4.0.6-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8851/samba-4.0.6-2.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-05-23 05:44:58 EDT
samba-4.0.6-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/samba-4.0.6-2.fc18
Comment 5 Stef Walter 2013-05-23 07:10:36 EDT
*** Bug 966436 has been marked as a duplicate of this bug. ***
Comment 6 Alexander Bokovoy 2013-05-23 11:45:25 EDT
*** Bug 966624 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2013-05-27 22:21:47 EDT
samba-4.0.6-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-06-04 17:02:17 EDT
samba-4.0.6-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.