Bug 966229 - register() api binding needs installed_products param
register() api binding needs installed_products param
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity high
: ---
: 1.3
Assigned To: Tom McKay
Vitaly Kuznetsov
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 16:02 EDT by Chris Duryee
Modified: 2013-10-01 07:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:10:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1390 normal SHIPPED_LIVE Release 1.3 of Subscription Asset Manager 2013-10-01 10:43:14 EDT

  None (edit)
Description Chris Duryee 2013-05-22 16:02:49 EDT
Description of problem:

the katello python api bindings do not support the "installed_products" parameter, which is needed by spacewalk-splice-tool.

Can the following commit be cherry-picked into katello-cli?

https://github.com/Katello/katello-cli/commit/ba79ceca965df78e314d8733961bea0c827ce9e4


Version-Release number of selected component (if applicable): 

katello-cli-1.4.2-5.el6sat.noarch
katello-cli-common-1.4.2-5.el6sat.noarch

How reproducible: every time


Steps to Reproduce:
1. run spacewalk-splice-tool --spacewalk-sync

Actual results:
Traceback (most recent call last):
  File "/usr/bin/spacewalk-splice-checkin", line 72, in <module>
    checkin.main(opts)
  File "/usr/lib/python2.6/site-packages/spacewalk_splice_tool/checkin.py", line 562, in main
    spacewalk_sync(options)
  File "/usr/lib/python2.6/site-packages/spacewalk_splice_tool/checkin.py", line 518, in spacewalk_sync
    upload_to_katello(consumers, katello_client)
  File "/usr/lib/python2.6/site-packages/spacewalk_splice_tool/checkin.py", line 429, in upload_to_katello
    owner=consumer['owner'])
  File "/usr/lib/python2.6/site-packages/spacewalk_splice_tool/katello_connect.py", line 130, in createConsumer
    facts=facts, activation_keys=None, cp_type='system', installed_products=installed_products)
TypeError: register() got an unexpected keyword argument 'installed_products'


Expected results: successful run
Comment 2 Sam Kottler 2013-05-23 19:41:44 EDT
Moving to ON_QA for drop 2.
Comment 3 Garik Khachikyan 2013-06-07 09:36:43 EDT
@Chris: not sure how you produced the bug as for me all the tries to install the spacewalk-splice-tool ends up on requiring splice-common which IS in brew but never built.

So please: i need more details (and rpms built with all deps there pls) thanks in advance.
Comment 10 Vitaly Kuznetsov 2013-09-10 11:31:19 EDT
Verified with:

spacewalk-splice-tool-0.40-1.el6sam.noarch
katello-cli-1.4.3-10.el6sat.noarch
katello-cli-common-1.4.3-10.el6sat.noarch
Comment 12 errata-xmlrpc 2013-10-01 07:10:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.