Bug 966277 - Adding information to Details tab for Content View Definitions
Adding information to Details tab for Content View Definitions
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 18:18 EDT by David Caplan
Modified: 2014-03-11 16:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-11 16:09:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen Shot of Content View Defn "Details" Selection (203.52 KB, image/tiff)
2013-05-22 18:18 EDT, David Caplan
no flags Details

  None (edit)
Description David Caplan 2013-05-22 18:18:18 EDT
Created attachment 751924 [details]
Screen Shot of Content View Defn "Details" Selection

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

when selecting Content View Definition from table and then selecting "Details" there are no details provided.

Actual results:
Only the name, label and description are shown


Expected results:

The structure of the CV definition should be depicted as a delineation of constituent components:
1. Names of all Content Views published from selected Definition
2. Location of all accessible Content VIews and versions at those locations
   This would: library and/or environments
3. Names of products and packages
4. Filter names applied and version ranges of included/excluded products if applicable
5. Errata type and date range if applicable

Other classes of information should include:
1. Total number of RPMs, Packages, Products (just the total of each type)
2. Total size in bytes of the Content
3. Membership in Composite Definition(s), parents identified


Additional info:
Comment 2 Brad Buckingham 2013-05-28 20:41:39 EDT
Much of the information listed in the expected results is available in the UI.  Since it is too much information for a single pane, it is structured per the UXD mockups.  That said, more details can be added and we can work on improving the layout, if needed.  We'll work with UXD to incorporate this feedback.

In the meantime, the following is where some of the items listed may be found:

1. Names of all Content Views published from selected Definition
   (UI Location: Views pane)

2. Location of all accessible Content VIews and versions at those locations.  This would: library and/or environments
   (UI Location: Views pane)

3. Names of products and packages
   (UI Location: Content pane (for products/repos), 
                 Content Search : Details on packages in a given published view.)

4. Filter names applied and version ranges of included/excluded products if applicable
   (UI Location: Not directly mapped as described)

5. Errata type and date range if applicable
   (UI Location: Filters -> Filter Rules)

For the 'other classes', those are largely not addressed in the Content View Definitions UI.
Comment 4 Brad Buckingham 2013-09-18 11:15:40 EDT
Since this BZ was opened, new mockups have been created for the content view (CV) UI and the implementation for that is planned for a future release (e.g. 6.0.3).  That said, the user may still find much of the information requested with the current implementation, as mentioned above.
Comment 5 Bryan Kearney 2014-03-11 16:09:18 EDT
new CV work makes this irrelevant.

Note You need to log in before you can comment on or make changes to this bug.