Bug 966299 - [abrt] cinnamon-1.8.3-1.fc19: XletSettings.py:146:build_single:UnboundLocalError: local variable 'instance_key' referenced before assignment
[abrt] cinnamon-1.8.3-1.fc19: XletSettings.py:146:build_single:UnboundLocalEr...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: leigh scott
Fedora Extras Quality Assurance
abrt_hash:2fa9bb1101a883cbaa3cf3ce8ff...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 20:52 EDT by D. Charles Pyle
Modified: 2013-05-23 04:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-23 02:32:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (711 bytes, text/plain)
2013-05-22 20:52 EDT, D. Charles Pyle
no flags Details
File: core_backtrace (330 bytes, text/plain)
2013-05-22 20:52 EDT, D. Charles Pyle
no flags Details
File: environ (1.83 KB, text/plain)
2013-05-22 20:52 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2013-05-22 20:52:31 EDT
Description of problem:
Tried to run a screensaver inhibitor applet.  Crash occurred on clicking the icon in the Applets control panel and clicking Configure button.

Version-Release number of selected component:
cinnamon-1.8.3-1.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        python /usr/lib/cinnamon-settings/cinnamon-settings.py
executable:     /usr/lib/cinnamon-settings/cinnamon-settings.py
kernel:         3.9.3-301.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
XletSettings.py:146:build_single:UnboundLocalError: local variable 'instance_key' referenced before assignment

Traceback (most recent call last):
  File "/usr/lib/cinnamon-settings/bin/ExtensionCore.py", line 992, in _configure_extension
    settingContainer = XletSettings.XletSetting(uuid, self, self.collection_type)
  File "/usr/lib/cinnamon-settings/bin/XletSettings.py", line 53, in __init__
    self.build_single()
  File "/usr/lib/cinnamon-settings/bin/XletSettings.py", line 146, in build_single
    self.current_id = instance_key
UnboundLocalError: local variable 'instance_key' referenced before assignment

Local variables in innermost frame:
self: <XletSettings.XletSetting instance at 0x1c6c1b8>
Comment 1 D. Charles Pyle 2013-05-22 20:52:34 EDT
Created attachment 751968 [details]
File: backtrace
Comment 2 D. Charles Pyle 2013-05-22 20:52:37 EDT
Created attachment 751969 [details]
File: core_backtrace
Comment 3 D. Charles Pyle 2013-05-22 20:52:39 EDT
Created attachment 751970 [details]
File: environ
Comment 4 leigh scott 2013-05-23 02:32:14 EDT
I haven't released 1.8.3 and I packaged the screen-saver/lock so the crash is expected.
Comment 5 leigh scott 2013-05-23 02:33:40 EDT
 I haven't released 1.8.3 and I haven't packaged the screen-saver/lock so the crash is expected.
Comment 6 leigh scott 2013-05-23 03:28:45 EDT
FYI all applets that you download are unsupported so in future file your issues against the relevant applet page.
I wouldn't expect any that use the old gjs dbus bindings to fail due to changes in gnome-3.8.

The F19 package is patched to work with gnome-3.8

http://pkgs.fedoraproject.org/cgit/cinnamon.git/tree/gnome-3.8-compat.patch

The thirdparty downloads aren't.
Comment 7 D. Charles Pyle 2013-05-23 04:15:59 EDT
I got this version of the cinnamon package through yum, which downloaded the package from a Fedora repository during updates, so it got into the repositories somehow even though you did not release it.

The screen locker works just fine without crashes and has been working for me for days--so long as that third-party screen-inhibitor applet isn't installed, that is.

Note You need to log in before you can comment on or make changes to this bug.