Bug 966317 - SELinux is preventing /usr/sbin/httpd from 'execute' accesses on the file /var/www/html/bugzilla/index.cgi.
SELinux is preventing /usr/sbin/httpd from 'execute' accesses on the file /va...
Status: CLOSED DUPLICATE of bug 966313
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:4d5b5095741565439f986223813...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-22 23:39 EDT by Moez Roy
Modified: 2013-05-23 04:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-23 04:16:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-05-22 23:39:41 EDT
Description of problem:
SELinux is preventing /usr/sbin/httpd from 'execute' accesses on the file /var/www/html/bugzilla/index.cgi.

*****  Plugin restorecon (99.5 confidence) suggests  *************************

If you want to fix the label. 
/var/www/html/bugzilla/index.cgi default label should be httpd_sys_content_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /var/www/html/bugzilla/index.cgi

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If you believe that httpd should be allowed execute access on the index.cgi file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep /usr/sbin/httpd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:httpd_t:s0
Target Context                unconfined_u:object_r:user_home_t:s0
Target Objects                /var/www/html/bugzilla/index.cgi [ file ]
Source                        /usr/sbin/httpd
Source Path                   /usr/sbin/httpd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           httpd-2.4.4-3.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-96.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.2-200.fc18.x86_64 #1 SMP Mon
                              May 13 13:59:47 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-05-22 20:37:35 PDT
Last Seen                     2013-05-22 20:37:37 PDT
Local ID                      df336f55-b1c5-4822-87fa-f280c27e7bb8

Raw Audit Messages
type=AVC msg=audit(1369280257.597:474): avc:  denied  { execute } for  pid=4157 comm="/usr/sbin/httpd" name="index.cgi" dev="sda2" ino=1319062 scontext=system_u:system_r:httpd_t:s0 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=file


type=SYSCALL msg=audit(1369280257.597:474): arch=x86_64 syscall=execve success=no exit=EACCES a0=7f2e6df1bad0 a1=7f2e6df1a1e8 a2=7f2e6df1a200 a3=7fff07c29b70 items=0 ppid=4084 pid=4157 auid=4294967295 uid=48 gid=48 euid=48 suid=48 fsuid=48 egid=48 sgid=48 fsgid=48 ses=4294967295 tty=(none) comm=/usr/sbin/httpd exe=/usr/sbin/httpd subj=system_u:system_r:httpd_t:s0 key=(null)

Hash: /usr/sbin/httpd,httpd_t,user_home_t,file,execute

audit2allow

#============= httpd_t ==============
allow httpd_t user_home_t:file execute;

audit2allow -R
require {
	type httpd_t;
}

#============= httpd_t ==============
userdom_mmap_user_home_content_files(httpd_t)


Additional info:
hashmarkername: setroubleshoot
kernel:         3.9.2-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-23 04:16:45 EDT

*** This bug has been marked as a duplicate of bug 966313 ***

Note You need to log in before you can comment on or make changes to this bug.