Bug 966320 - ovirt node will also enable ipv4 with dhcp protocol when only setting ipv6 with dhcp
ovirt node will also enable ipv4 with dhcp protocol when only setting ipv6 wi...
Status: CLOSED WORKSFORME
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
high Severity high
: ---
: 3.4.3
Assigned To: Ryan Barry
bugs@ovirt.org
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 00:08 EDT by haiyang,dong
Modified: 2014-05-08 22:08 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-08 22:08:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached Screenshot for NIC Details page (51.30 KB, image/png)
2013-05-23 00:08 EDT, haiyang,dong
no flags Details
attached Screenshot for status page (59.23 KB, image/png)
2013-05-23 00:10 EDT, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2013-05-23 00:08:37 EDT
Created attachment 751983 [details]
attached Screenshot for NIC Details page

Description of problem:
Install ovirt node and enter into NIC Details page, only setting ipv6 with dhcp:
┌────────────────────────────── NIC Details: em1 ──────────────────────────────┐
│NIC Details: em1                                                              │
│Interface:  em1                       Driver:     e1000e                      │
│Protocol:   dhcp                      Vendor:     Intel Corporation           │
│Link Status: Connected                MAC Address: 78:2b:cb:9a:72:a3          │
│                                                                              │
│IPv4 Settings                                                                 │
│                                                                              │
│Bootprotocol:      (X) Disabled       ( ) DHCP           ( ) Static           │
│                                                                              │
│IP Address:        ___________________  Netmask:         ___________________  │
│Gateway:           ___________________                                        │
│                                                                              │
│IPv6 Settings                                                                 │
│                                                                              │
│Bootprotocol:  ( ) Disabled   ( ) Auto       (X) DHCP        ( ) Static       │
│                                                                              │
│IP Address:        ___________________  Netmask:         ___________________  │
│Gateway:           ___________________                                        │
│                                                                              │
│VLAN ID:           ___________________                                        │

but after configuring ipv6 with dhcp success, check that:
[root@localhost admin]# ip -o addr show brem1
3: brem1    inet 10.66.8.172/22 brd 10.66.11.255 scope global brem1\       valid_lft forever preferred_lft forever
3: brem1    inet6 3ffe:3240:8008:1000::135/64 scope global \       valid_lft forever preferred_lft forever
3: brem1    inet6 fe80::7a2b:cbff:fe9a:72a3/64 scope link \       valid_lft forever preferred_lft forever

[root@localhost admin]# cat /etc/sysconfig/network-scripts/ifcfg-brem1 
DEVICE=brem1
TYPE=Bridge
PEERNTP=yes
DELAY=0
IPV6INIT=yes
IPV6_AUTOCONF=no
IPV6FORWARDING=no
DHCPV6C=yes
BOOTPROTO=dhcp
ONBOOT=yes

[root@localhost admin]# cat /etc/sysconfig/network-scripts/ifcfg-em1 
DEVICE=em1
HWADDR=78:2b:cb:9a:72:a3
BRIDGE=brem1
ONBOOT=yes

I found the follow issues:
1. ovirt node will also enable ipv4 with dhcp protocol when only setting ipv6 with dhcp(Need deleted "BOOTPROTO=dhcp" from ifcfg-brem1)
(Seen status.png)                               
2. These items of ipv6 setting: "IP Address","Netmask" and "Gateway" shown blank(Seen NIC Details page.png)
3. It shown ipv6 link address on status page, actually we want it show ipv6 global address(Seen status.png)


 

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-1.0.20130517.fc18.iso

How reproducible:
100%

Steps to Reproduce:

Actual result:

          
                                                  
Expect result:
1. ovirt node disable ipv4 with dhcp protocol when only setting ipv6 with dhcp(Need deleted "BOOTPROTO=dhcp" from ifcfg-brem1)                              
2. These items of ipv6 setting: "IP Address","Netmask" and "Gateway" shown configured info
3. It show ipv6 global address on status page

Additional info:
Comment 1 haiyang,dong 2013-05-23 00:10:46 EDT
Created attachment 751984 [details]
attached Screenshot for status page
Comment 2 Fabian Deutsch 2013-05-23 07:20:47 EDT
This needs some work on the backend networking code.
Comment 3 Sandro Bonazzola 2014-03-04 04:20:43 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 4 Ryan Barry 2014-05-07 11:46:09 EDT
I'm not able to reproduce this. Is this still reproducable?
Comment 5 haiyang,dong 2014-05-07 23:01:31 EDT
(In reply to Ryan Barry from comment #4)
> I'm not able to reproduce this. Is this still reproducable?

If you want to reproduce this bug, please use version ovirt-node-iso-3.0.0-1.0.20130517.fc18.iso to check.

Also i checked that this bug has been fixed in ovirt-node-iso-3.4-20140423.1.el6.iso
Comment 6 Ryan Barry 2014-05-08 10:17:47 EDT
Just one last check --

Is this reproducable downstream? I can't get it to occur. I suspect that the network backend rewrite fixed this, and this can be closed.
Comment 7 haiyang,dong 2014-05-08 21:58:30 EDT
(In reply to Ryan Barry from comment #6)
> Just one last check --
> 
> Is this reproducable downstream? I can't get it to occur. I suspect that the
> network backend rewrite fixed this, and this can be closed.

Confirm that this bug has been fixed in ovirt-ndoe downstream version:
rhevh-6.5-20140430.0.iso
ovirt-node-3.0.1-18.el6_5.10.noarch

Note You need to log in before you can comment on or make changes to this bug.