Bug 966341 - Failed to run numatune with specified node
Failed to run numatune with specified node
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 02:04 EDT by Luwen Su
Modified: 2014-06-13 05:46 EDT (History)
7 users (show)

See Also:
Fixed In Version: libvirt-1.1.1-18.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 05:46:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luwen Su 2013-05-23 02:04:29 EDT
Description of problem:
Since Bug 920406 just fix the error messeg when fail to write into cpuset.mems , and it's a kernel issue about fail to run numatune with specified node , so file this one to track in libvirt field.



Version-Release number of selected component (if applicable):
libvirt-1.0.5-2.el7.x86_64
kernel-3.9.0-0.55.el7.x86_64


How reproducible:
100%

Steps to Reproduce:
1.A guest and a numa host
# virsh list
 Id    Name                           State
----------------------------------------------------
 2     test                           running


# virsh nodeinfo
CPU model:           x86_64
CPU(s):              12
CPU frequency:       800 MHz
CPU socket(s):       1
Core(s) per socket:  6
Thread(s) per core:  1
NUMA cell(s):        2
Memory size:         32686424 KiB



2.
# virsh numatune test --nodeset 0
error: Unable to change numa parameters
error: unable to set numa tunable: Device or resource busy

# virsh numatune test --nodeset 0-1

# virsh numatune test --nodeset 1
error: Unable to change numa parameters
error: unable to set numa tunable: Device or resource busy

# virsh numatune test --nodeset 99
error: Unable to change numa parameters
error: unable to set numa tunable: Invalid argument


#echo 0 > /sys/fs/cgroup/cpuset/machine/test.libvirt-qemu/cpuset.mems 
-bash: echo: write error: Device or resource busy


Actual results:
Fail to write into cpuset.mems

Expected results:
Success
Comment 2 Wayne Sun 2013-11-20 02:21:50 EST
Depend bug 955489 is still new, waiting for it to be resolved.
Comment 4 Ján Tomko 2014-03-28 05:38:58 EDT
This was not a kernel issue and has been fixed in upstream libvirt by
commit 81fae6b95cfe72d0f5a987b6b5cd4bf86e32798c
Author:     Shivaprasad G Bhat <shivaprasadbhat@gmail.com>
AuthorDate: 2013-12-03 06:30:26 -0500
Commit:     Martin Kletzander <mkletzan@redhat.com>
CommitDate: 2013-12-04 13:32:07 +0100

    qemu: fix live pinning to memory node on NUMA system
    
    Ever since the subcpusets(vcpu,emulator) were introduced, the parent
    cpuset cannot be modified to remove the nodes that are in use by the
    subcpusets.
    The fix is to break the memory node modification into three steps:
     1. assign new nodes into the parent,
     2. change the nodes in the child nodes,
     3. remove the old nodes on the parent node.
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1009880
    
    Signed-off-by: Shivaprasad G Bhat <sbhat@linux.vnet.ibm.com>
    Signed-off-by: Martin Kletzander <mkletzan@redhat.com>

git describe: v1.2.0-43-g81fae6b contains: v1.2.1-rc1~208
Comment 6 Jincheng Miao 2014-03-31 05:01:53 EDT
in latest libvirt-1.1.1-29.el7.x86_64, the operation of specify nodeset is working.

# rpm -q libvirt kernel
libvirt-1.1.1-29.el7.x86_64
kernel-3.10.0-115.el7.x86_64

# virsh nodeinfo
CPU model:           x86_64
CPU(s):              32
CPU frequency:       1064 MHz
CPU socket(s):       1
Core(s) per socket:  8
Thread(s) per core:  2
NUMA cell(s):        2
Memory size:         131908736 KiB

# virsh start r7
Domain r7 started

# virsh numatune r7 --nodeset 1

# cat /sys/fs/cgroup/cpuset/machine.slice/machine-qemu\\x2dr7.scope/cpuset.mems 
1

# virsh numatune r7 --nodeset 0

# cat /sys/fs/cgroup/cpuset/machine.slice/machine-qemu\\x2dr7.scope/cpuset.mems 
0

# virsh numatune r7 --nodeset 0-1

# cat /sys/fs/cgroup/cpuset/machine.slice/machine-qemu\\x2dr7.scope/cpuset.mems 
0-1

# virsh numatune r7 --nodeset 2
error: Unable to change numa parameters
error: Unable to write to '/sys/fs/cgroup/cpuset/machine.slice/machine-qemu\x2dr7.scope/vcpu0/cpuset.mems': Invalid argument
Comment 7 Jincheng Miao 2014-04-08 02:55:06 EDT
As comment 6, this bug is fixed in the latest libvirt-1.1.1-29.el7.x86_64, so change the status to VERIFIED.
Comment 9 Ludek Smid 2014-06-13 05:46:15 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.