Bug 966361 - Provide more clear error msg if source file not exist when add mount point manually
Provide more clear error msg if source file not exist when add mount point ma...
Status: CLOSED DUPLICATE of bug 927072
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt-sandbox (Show other bugs)
7.0
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Daniel Berrange
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 03:04 EDT by zhe peng
Modified: 2013-10-15 06:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 06:01:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhe peng 2013-05-23 03:04:24 EDT
Description
provide more clear error msg if source file not existing when add mount point manually.

Versions
libvirt-1.0.5-2.el7.x86_64
libvirt-sandbox-0.2.0-1.el7.x86_64

Steps:
1:create and start a lxc container
#virt-sandbox-service create -C -u httpd.service http1
2:edit config file
#vi /etc/libvirt-sandbox/services/http1.sandbox

add a new mount point,the source file not exist.
......
[mount.17]
type=GVirSandboxConfigMountHostBind
target=/var/log/log
source=/tmp/log
....

3:start the container.
# virt-sandbox-service start http1
Unable to start container: Failed to create domain: internal error guest failed to start: PATH=/bin:/sbin TERM=linux container=lxc-libvirt container_uuid=13f0f835-70e0-4f3a-97ad-aa204fae6e1f LIBVIRT_LXC_UUID=13f0f835-70e0-4f3a-97ad-aa204fae6e1f LIBVIRT_LXC_NAME=http1 /usr/libexec/libvirt-sandbox-init-lxc
error receiving signal from container: Input/output error

Expected results:
the error msg should be more clear. like : miss source file /tmp/log.

Actual results:
see step

Additional info:
Comment 2 Daniel Berrange 2013-10-15 06:01:17 EDT
This is not really a libvit-sandbox error - it is caused by libvirt bug 927072

*** This bug has been marked as a duplicate of bug 927072 ***

Note You need to log in before you can comment on or make changes to this bug.