Bug 966386 - Kdump with "Local" mode will not be successd and host hangs on
Kdump with "Local" mode will not be successd and host hangs on
Status: CLOSED WORKSFORME
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.5.0
Assigned To: Ryan Barry
bugs@ovirt.org
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 04:26 EDT by wanghui
Modified: 2016-02-10 14:39 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-11 10:15:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wanghui 2013-05-23 04:26:00 EDT
Description of problem:
When configured Kdump with "Local" mode and trigger a core dump, it will lead to the host hangs on.

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-1.0.20130517.fc18
ovirt-node-3.0.0-1.0.fc18.noarch  

How reproducible:
100%

Steps to Reproduce:
1. Install ovirt-node-upstream, configure Kdump with "Local" mode.
2. drop to shell and run # echo c>/proc/sysrq-trigger

Actual results:
Host will hang on and kdump with "Local" mode will not be succeed.

Expected results:
Host can reboot and kdump will be succeed.

Additional info:
Comment 1 Fabian Deutsch 2013-11-28 09:54:27 EST
Hey,

can you please check if this still exists with 3.0.3?
Comment 2 wanghui 2013-11-29 03:18:13 EST
Test version:
ovirt-node-iso-3.0.3-1.1.fc19.iso
ovirt-node-3.0.3-1.1.fc19.noarch

Test step:
1. Install ovirt-node-iso-3.0.3-1.1.fc19.iso, configure Kdump with "Local" mode.
2. drop to shell and run # echo c>/proc/sysrq-trigger

Test result:
1. After step2,host will hang on and kdump with "Local" mode will not be succeed.

So this problem still exists in ovirt-node-iso-3.0.3-1.1.fc19.iso.
Comment 3 Sandro Bonazzola 2014-03-04 04:20:14 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 4 Sandro Bonazzola 2014-05-08 09:55:47 EDT
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.
Comment 5 Itamar Heim 2014-08-10 16:38:14 EDT
is this still relevant? iiuc, we configure in 3.5 kdump as part of engine deployment?
Comment 6 Ryan Barry 2014-08-10 19:29:56 EDT
I wasn't able to reproduce this last time I tried, but IIUC, this is about the Local kdump target failing to work once configured. 

We do now configure kdump as part of the Node install, but that's a different issue.

Are we still able to reproduce this with current EL6 images?
Comment 7 wanghui 2014-08-10 23:02:34 EDT
Test version:
ovirt-node-base-iso-3.1.0_master-20140810.0.el6.iso
ovirt-node-3.1.0-0.0.master.20140808.git31bb477.el6.noarch

Test step:
1. Clean install ovirt-node-base-iso-3.1.0_master-20140810.0.el6.iso.
2. drop to shell and run # echo c>/proc/sysrq-trigger

Test result:
1. After step2, it can dump kernel info to local path succeed.

Because we change the local as default kdump configuration, it's not the same situation as before now. And it can not reproduce in current ovirt-node-base-iso-3.1.0_master-20140810.0.el6.iso image.

Note You need to log in before you can comment on or make changes to this bug.