Bug 966399 - eruby-libs-1.0.5-21.fc18.i686.rpm dependency problem
eruby-libs-1.0.5-21.fc18.i686.rpm dependency problem
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eruby (Show other bugs)
18
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Luis Bazan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 04:46 EDT by Roy A. Gilmore
Modified: 2013-06-28 02:11 EDT (History)
1 user (show)

See Also:
Fixed In Version: eruby-1.0.5-24.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 02:11:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roy A. Gilmore 2013-05-23 04:46:04 EDT
Description of problem:
eruby-libs-1.0.5-21.fc18.i686.rpm won't update because missing dependency: ruby(release)

Version-Release number of selected component (if applicable):
eruby-libs-1.0.5-21.fc18.i686.rpm

How reproducible:
every time

Steps to Reproduce:
1. yum makecache
2. yum --skip-broken distro-sync

Actual results:
[root@thor ~]# yum --skip-broken distro-sync
Loaded plugins: auto-update-debuginfo, fastestmirror, langpacks, presto, priorities, refresh-packagekit, remove-with-leaves, rpm-
              : warm-cache
Loading mirror speeds from cached hostfile
 * fedora: fedora.mirror.gtcomm.net
 * livna: rpm.livna.org
 * rpmfusion-free: mirror.liberty.edu
 * rpmfusion-free-updates: mirror.liberty.edu
 * rpmfusion-nonfree: mirror.liberty.edu
 * rpmfusion-nonfree-updates: mirror.liberty.edu
 * updates: fedora.mirror.gtcomm.net
24 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package eruby.i686 0:1.0.5-19.fc18 will be updated
---> Package eruby.i686 0:1.0.5-21.fc18 will be an update
---> Package eruby-devel.i686 0:1.0.5-19.fc18 will be updated
---> Package eruby-devel.i686 0:1.0.5-21.fc18 will be an update
---> Package eruby-libs.i686 0:1.0.5-19.fc18 will be updated
---> Package eruby-libs.i686 0:1.0.5-21.fc18 will be an update
--> Processing Dependency: ruby(release) for package: eruby-libs-1.0.5-21.fc18.i686
--> Running transaction check
---> Package eruby.i686 0:1.0.5-19.fc18 will be updated
---> Package eruby-devel.i686 0:1.0.5-19.fc18 will be updated

Packages skipped because of dependency problems:
    eruby-1.0.5-21.fc18.i686 from updates
    eruby-devel-1.0.5-21.fc18.i686 from updates
    eruby-libs-1.0.5-21.fc18.i686 from updates

Expected results:
success

Additional info:
did:
[root@thor ~]# yumdownloader eruby-libs

then:
[root@thor ~]# rpm -q --requires -p eruby-libs-1.0.5-21.fc18.i686.rpm
/sbin/ldconfig
/sbin/ldconfig
libc.so.6
libc.so.6(GLIBC_2.0)
libc.so.6(GLIBC_2.1.3)
libc.so.6(GLIBC_2.3)
libc.so.6(GLIBC_2.3.4)
libcrypt.so.1
libdl.so.2
liberuby.so.1.0
libm.so.6
libpthread.so.0
librt.so.1
libruby.so.1.9
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)
ruby(release)
rpmlib(PayloadIsXz) <= 5.2-1

then:
[root@thor ~]# yum --enablerepo=updates-testing provides ruby\(release\)
Loaded plugins: auto-update-debuginfo, fastestmirror, langpacks, presto, priorities, refresh-packagekit, remove-with-leaves, rpm-
              : warm-cache
Loading mirror speeds from cached hostfile
 * fedora: fedora.mirror.gtcomm.net
 * livna: rpm.livna.org
 * rpmfusion-free: mirror.liberty.edu
 * rpmfusion-free-updates: mirror.liberty.edu
 * rpmfusion-nonfree: mirror.liberty.edu
 * rpmfusion-nonfree-updates: mirror.liberty.edu
 * updates: fedora.mirror.gtcomm.net
 * updates-testing: fedora.mirrors.pair.com
24 packages excluded due to repository priority protections
No Matches found

eruby-libs requires ruby(release) yet no package provides it. Does the maintainer have a non-standard package or macro that provides it? Or am I missing something?
Comment 1 Fedora Update System 2013-06-18 09:58:47 EDT
eruby-1.0.5-23.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/eruby-1.0.5-23.fc18
Comment 2 Fedora Update System 2013-06-19 00:31:41 EDT
Package eruby-1.0.5-23.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eruby-1.0.5-23.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11218/eruby-1.0.5-23.fc18
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-06-20 22:02:26 EDT
Package eruby-1.0.5-24.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eruby-1.0.5-24.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11218/eruby-1.0.5-24.fc18
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-06-28 02:11:35 EDT
eruby-1.0.5-24.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.