Bug 966450 - "rebuild error Error" is shown when git push for nodetime quickstart and farmstand-nodejs-mongodb-example
"rebuild error Error" is shown when git push for nodetime quickstart and farm...
Status: CLOSED CANTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Ben Parees
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 06:16 EDT by Wei Sun
Modified: 2015-06-28 23:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-28 23:54:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2013-05-23 06:16:36 EDT
Description of problem:
Create nodetime quickstart as follow README.md,but when git push,some error messages are shown,like
remote: gyp WARN install got an error, rolling back install
remote: gyp ERR! rebuild error Error: EXDEV, link '/usr/lib/node_modules/npm/node_modules/node-gyp/legacy/tools/gyp/gyptest.pyc'
remote: gyp ERR! not ok 


Version-Release number of selected component (if applicable):
https://github.com/openshift/nodefly-openshift-quickstart

devenv_3262

How reproducible:
Always

Steps to Reproduce:
1.Create nodetime quickstart as follow https://github.com/openshift/nodefly-openshift-quickstart
2.
3.

Actual results:
[sunwei@dhcp-8-229 nodetime]$ gitpush 
[master e29a776] test
 1 file changed, 1 insertion(+), 1 deletion(-)
Counting objects: 5, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (3/3), done.
Writing objects: 100% (3/3), 274 bytes, done.
Total 3 (delta 2), reused 0 (delta 0)
remote: Saving away previously installed Node modules
remote: npm info it worked if it ends with ok
remote: npm info using npm@1.1.37
remote: npm info using node@v0.6.20
remote: npm info preinstall OpenShift-Sample-App@1.0.0
remote: npm info retry registry request attempt 1 at 05:57:22
remote: npm http GET https://registry.npmjs.org/nodetime
remote: npm http 304 https://registry.npmjs.org/nodetime
remote: npm info install nodetime@0.8.12 into /var/lib/openshift/8a154f06c38b11e28fab22000a976a34/app-root/runtime/repo
remote: npm info installOne nodetime@0.8.12
remote: npm info /var/lib/openshift/8a154f06c38b11e28fab22000a976a34/app-root/runtime/repo/node_modules/nodetime unbuild
remote: npm info preinstall nodetime@0.8.12
remote: npm info retry registry request attempt 1 at 05:57:29
remote: npm http GET https://registry.npmjs.org/nodetime-native/0.1.0
remote: npm http 304 https://registry.npmjs.org/nodetime-native/0.1.0
remote: npm info install nodetime-native@0.1.0 into /var/lib/openshift/8a154f06c38b11e28fab22000a976a34/app-root/runtime/repo/node_modules/nodetime
remote: npm info installOne nodetime-native@0.1.0
remote: npm info /var/lib/openshift/8a154f06c38b11e28fab22000a976a34/app-root/runtime/repo/node_modules/nodetime/node_modules/nodetime-native unbuild
remote: npm info preinstall nodetime-native@0.1.0
remote: npm info retry registry request attempt 1 at 05:57:29
remote: npm http GET https://registry.npmjs.org/bindings
remote: npm http 304 https://registry.npmjs.org/bindings
remote: npm info install bindings@1.1.0 into /var/lib/openshift/8a154f06c38b11e28fab22000a976a34/app-root/runtime/repo/node_modules/nodetime/node_modules/nodetime-native
remote: npm info installOne bindings@1.1.0
remote: npm info /var/lib/openshift/8a154f06c38b11e28fab22000a976a34/app-root/runtime/repo/node_modules/nodetime/node_modules/nodetime-native/node_modules/bindings unbuild
remote: npm info preinstall bindings@1.1.0
remote: npm info build /var/lib/openshift/8a154f06c38b11e28fab22000a976a34/app-root/runtime/repo/node_modules/nodetime/node_modules/nodetime-native/node_modules/bindings
remote: npm info linkStuff bindings@1.1.0
remote: npm info install bindings@1.1.0
remote: npm info postinstall bindings@1.1.0
remote: npm info build /var/lib/openshift/8a154f06c38b11e28fab22000a976a34/app-root/runtime/repo/node_modules/nodetime/node_modules/nodetime-native
remote: npm info linkStuff nodetime-native@0.1.0
remote: npm info install nodetime-native@0.1.0
remote: 
remote: > nodetime-native@0.1.0 install /var/lib/openshift/8a154f06c38b11e28fab22000a976a34/app-root/runtime/repo/node_modules/nodetime/node_modules/nodetime-native
remote: > node-gyp rebuild
remote: 
remote: gyp info it worked if it ends with ok
remote: gyp info using node-gyp@0.5.2
remote: gyp info using node@0.6.20
remote: gyp http GET http://nodejs.org/dist/v0.6.20/node-v0.6.20.tar.gz
remote: gyp http 200 http://nodejs.org/dist/v0.6.20/node-v0.6.20.tar.gz
remote: gyp WARN install got an error, rolling back install
remote: gyp ERR! rebuild error Error: EXDEV, link '/usr/lib/node_modules/npm/node_modules/node-gyp/legacy/tools/gyp/gyptest.pyc'
remote: gyp ERR! not ok 
remote: npm info nodetime-native@0.1.0 Failed to exec install script
remote: npm info /var/lib/openshift/8a154f06c38b11e28fab22000a976a34/app-root/runtime/repo/node_modules/nodetime/node_modules/nodetime-native unbuild
remote: npm info preuninstall nodetime-native@0.1.0
remote: npm info uninstall nodetime-native@0.1.0
remote: npm info postuninstall nodetime-native@0.1.0
remote: npm WARN optional dep failed, continuing nodetime-native@0.1.0
remote: npm info build /var/lib/openshift/8a154f06c38b11e28fab22000a976a34/app-root/runtime/repo/node_modules/nodetime
remote: npm info linkStuff nodetime@0.8.12
remote: npm info install nodetime@0.8.12
remote: npm info postinstall nodetime@0.8.12
remote: npm info build /var/lib/openshift/8a154f06c38b11e28fab22000a976a34/app-root/runtime/repo
remote: npm info linkStuff OpenShift-Sample-App@1.0.0
remote: npm info install OpenShift-Sample-App@1.0.0
remote: npm info postinstall OpenShift-Sample-App@1.0.0
remote: npm info ok 
remote: nodetime@0.8.12 node_modules/nodetime
To ssh://8a154f06c38b11e28fab22000a976a34@nodetime-wsundevn3261.dev.rhcloud.com/~/git/nodetime.git/
   577c3d1..e29a776  master -> master


Expected results:
Can git push successfully

Additional info:
Comment 1 Mrunal Patel 2013-05-23 19:33:22 EDT
Our version of nodejs is old. This works fine when used with
https://github.com/openshift/nodejs-custom-version-openshift
Comment 2 Dan McPherson 2013-06-01 20:56:28 EDT
I am adding farmstand to this bug as they appear to be the same problem:

Description of problem:
Create farmstand-nodejs-mongodb-example  quickstart as follow README.md.But failed to git push.It shows some error messages,like
remote: Failed to execute: 'control build' for /var/lib/openshift/421340315062835938852864/nodejs: rc(1)


Version-Release number of selected component (if applicable):
devenv_3223
https://github.com/openshift/farmstand-nodejs-mongodb-example

How reproducible:
Always

Steps to Reproduce:
1.Create quickstart as follow https://github.com/openshift/farmstand-nodejs-mongodb-example
2.
3.
  
Actual results:
1.openshift@openshift-ubuntu:~/test/nd$ git push
----------skip---------------------
remote: gyp ERR! configure error Error: EXDEV, link '/usr/lib/node_modules/npm/node_modules/node-gyp/legacy/tools/gyp/gyptest.pyc'
remote: gyp ERR! not ok 
remote: gmake: *** [node_gyp] Error 1
remote: child process exited with code 2
remote: npm info postinstall bson@0.1.5
remote: npm info build /var/lib/openshift/421340315062835938852864/app-root/runtime/repo/node_modules/mongodb
remote: npm info linkStuff mongodb@1.1.11
remote: npm info install mongodb@1.1.11
remote: npm info postinstall mongodb@1.1.11
remote: npm ERR! 
remote: npm ERR! Additional logging details can be found in:
remote: npm ERR!     /var/lib/openshift/421340315062835938852864/app-root/runtime/repo/npm-debug.log
remote: npm ERR! not ok code undefined
remote: npm ERR! not ok code 1
remote: Failed to execute: 'control build' for /var/lib/openshift/421340315062835938852864/nodejs: rc(1)
remote: stdout: #<IO:0x0000000150d2b8>
remote: stderr#<IO:0x0000000150d240>
remote: /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.9.1/lib/openshift-origin-node/model/v2_cart_model.rb:950:in `block in do_control_with_directory'
remote: /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.9.1/lib/openshift-origin-node/model/v2_cart_model.rb:776:in `process_cartridges'
remote: /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.9.1/lib/openshift-origin-node/model/v2_cart_model.rb:923:in `do_control_with_directory'
remote: /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.9.1/lib/openshift-origin-node/model/v2_cart_model.rb:799:in `do_control'
remote: /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.9.1/lib/openshift-origin-node/model/application_container.rb:502:in `build'
remote: /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.9.1/lib/openshift-origin-node/model/default_builder.rb:37:in `post_receive'
remote: /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.9.1/lib/openshift-origin-node/model/application_container.rb:421:in `post_receive'
remote: /usr/bin/gear:133:in `block (3 levels) in <main>'
remote: /usr/bin/gear:80:in `do_command'
remote: /usr/bin/gear:132:in `block (2 levels) in <main>'
remote: /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'
remote: /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'
remote: /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:155:in `run'
remote: /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/runner.rb:385:in `run_active_command'
remote: /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/runner.rb:62:in `run!'
remote: /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/delegates.rb:11:in `run!'
remote: /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/import.rb:10:in `block in <top (required)>'



Expected results:
Can create it successfully

Additional info:
Comment 3 Fotios Lindiakos 2013-06-19 18:08:15 EDT
The farmstand quickstart currently works with our nodejs cart, we had to bump the jquery version as well as fix the env variables. [1]

The original description is misleading. Nodefly *DOES* work, but nodetime *DOES NOT* (as evidenced in the stack trace).

There is a pull request in for nodetime to use the updated ENV variables. But as Mrunal pointed out, this will not work with our current nodejs version. [2]

[1]: https://github.com/openshift/farmstand-nodejs-mongodb-example/commit/af6a6e82bb571bdc771dbd1af7589db8eead6b3c
[2]: https://github.com/nodetime/nodetime-openshift-quickstart/pull/2
Comment 4 manoj 2013-09-18 14:58:56 EDT
Need to retest .10 Nodejs
Comment 5 Ben Parees 2015-06-25 17:34:10 EDT
the original repo (https://github.com/openshift/nodefly-openshift-quickstart) no longer exists.

the https://github.com/nodetime/nodetime-openshift-quickstart repo appears to be abandoned, the pull was never merged.

i'm inclined to close this.  QE is there anything else you'd like to do with it?
Comment 6 Wei Sun 2015-06-28 22:27:16 EDT
Since the original repo (https://github.com/openshift/nodefly-openshift-quickstart) no longer exists,close this bug is ok for me.

Note You need to log in before you can comment on or make changes to this bug.