Bug 966456 - the former buglist URL for searching flags can't work now
the former buglist URL for searching flags can't work now
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.4
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 06:19 EDT by wangjing
Modified: 2014-10-12 18:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-23 06:47:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wangjing 2013-05-23 06:19:27 EDT
Description of problem:
to ticket 204341, the former used bugzilla search buglist URL doesn't work on current version.

Version-Release number of selected component (if applicable):
prod env version 4.4.rc2-3

How reproducible:
always.

Steps to Reproduce:
1. login as redhat account, visit the former used buglist URL: 
https://bugzilla.redhat.com/buglist.cgi?f1=blocked&columnlist=component%2Cassigned_to%2Cqa_contact%2Cflagtypes.name%2Cshort_desc&o1=nowordssubstr&classification=Red%20Hat&o2=allwordssubstr&query_format=advanced&f2=flagtypes.name&bug_status=NEW&bug_status=ASSIGNED&bug_status=POST&bug_status=MODIFIED&bug_status=ON_DEV&bug_status=ON_QA&bug_status=VERIFIED&v1=960070&component=kernel&v2=qa_ack%2B%206.5.0&product=Red%20Hat%20Enterprise%20Linux%206&list_id=1391077
2. check the result:

Actual results:
No results were found that matched your query.

Expected results:
buglist should be returned. 

Additional info:
the reason is, in Custom Search section, if we need to search for two flags, we should set two conditions seperately on current version, but in this former URL, the conditions were set as 'Flags' 'contains all of the strings' 'qa_ack+ 6.5.0',  they put the two flags together in one.

So on current version, the former URLs for users could not be used.
Comment 1 Simon Green 2013-05-23 06:47:55 EDT
This is intentional. The upstream bug relating to this change is https://bugzilla.mozilla.org/show_bug.cgi?id=828344

Note You need to log in before you can comment on or make changes to this bug.