Bug 966465 - Return "Internal Server Error" for openshift-mongo-flask-example quickstarts
Return "Internal Server Error" for openshift-mongo-flask-example quickstarts
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Templates (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
: 968121 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 06:22 EDT by Wei Sun
Modified: 2015-05-14 22:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 00:09:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2013-05-23 06:22:19 EDT
Description of problem:
Create flask-example and openshift-mongo-flask-example as follow README.md,and try to access app's url,but it returns "Internal Server Error".

Version-Release number of selected component (if applicable):
https://github.com/openshift/flask-example
https://github.com/openshift/openshift-mongo-flask-example

devenv_3262

How reproducible:
Always

Steps to Reproduce:
1.Create quickstarts as follow README.md,for example: https://github.com/openshift/flask-example
2.Access the app's url
3.

Actual results:
Return "Internal Server Error"

Expected results:
Can access the app's url

Additional info:
Comment 1 Dan McPherson 2013-05-28 11:29:23 EDT
Appears not to be a regression from v1.  The error I am getting is:

remote: Reading http://mirror1.ops.rhcloud.com/mirror/python/web/simple/markupsafe/
remote: Couldn't find index page for 'markupsafe' (maybe misspelled?)
remote: Scanning index of all packages (this may take a while)
remote: Reading http://mirror1.ops.rhcloud.com/mirror/python/web/simple/
remote: No local packages or download links found for markupsafe
Comment 3 Dan McPherson 2013-05-28 23:02:26 EDT
*** Bug 968121 has been marked as a duplicate of this bug. ***
Comment 4 Mrunal Patel 2013-05-29 01:51:36 EDT
Pushed fix for https://github.com/openshift/flask-example
Comment 5 Andy Grimm 2013-05-29 08:39:26 EDT
This has also been fixed in Jinja2, so after their next release, we can undo the workaround.

https://github.com/mitsuhiko/jinja2/commit/70a2bc0e58c211bdd86e89abd29ec12b2387b6fa
Comment 6 Wei Sun 2013-05-30 01:23:15 EDT
Check this bug on devenv_3288
flask-example is fixed.But openshift-mongo-flask-exampl is not fixed,still return "Internal Server Error".
Comment 7 Dan McPherson 2013-06-01 21:12:14 EDT
Pushed fix for: openshift-mongo-flask-example
Comment 8 Wei Sun 2013-06-03 21:42:35 EDT
Verified on STG(devenv-stage_357), openshift-mongo-flask-exampl is fixed.

Note You need to log in before you can comment on or make changes to this bug.