Bug 966532 - qt-creator segfault
qt-creator segfault
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qt-creator (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Itamar Reis Peixoto
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 08:34 EDT by Mildred
Modified: 2013-10-17 17:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 17:53:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mildred 2013-05-23 08:34:54 EDT
Description of problem:
When loading a file, sometimes, qt-creator crashes with SIGSEGV.


Version-Release number of selected component (if applicable):
qt-creator-2.7.0-1.fc18.x86_64


How reproducible: very often but not always at the same point. Can't keep it running for very long though (except by doing nothing)


Steps to Reproduce:
1. Load qt-creator and open files, follow C++ references, ...

Actual results: Crash


Additional info:

I used gdb to see what happened, and I got the following stack trace:

#0  0x00007fffe74be677 in CPlusPlus::Type::isFunctionType() const () from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#1  0x00007fffe7a53be6 in CPlusPlus::CheckSymbols::maybeAddField(QList<CPlusPlus::LookupItem> const&, CPlusPlus::NameAST*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/libCppTools.so
#2  0x00007fffe7a53d9c in CPlusPlus::CheckSymbols::visit(CPlusPlus::MemberAccessAST*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/libCppTools.so
#3  0x00007fffe74755c3 in CPlusPlus::MemberAccessAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#4  0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#5  0x00007fffe74732f8 in CPlusPlus::DeclaratorAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#6  0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#7  0x00007fffe7a54d30 in CPlusPlus::CheckSymbols::visit(CPlusPlus::SimpleDeclarationAST*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/libCppTools.so
#8  0x00007fffe7473319 in CPlusPlus::SimpleDeclarationAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#9  0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#10 0x00007fffe7473fb1 in CPlusPlus::DeclarationStatementAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#11 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#12 0x00007fffe7473d49 in CPlusPlus::CompoundStatementAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#13 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#14 0x00007fffe74749f2 in CPlusPlus::IfStatementAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#15 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#16 0x00007fffe7474a03 in CPlusPlus::IfStatementAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#17 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#18 0x00007fffe7474a03 in CPlusPlus::IfStatementAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#19 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#20 0x00007fffe7474a03 in CPlusPlus::IfStatementAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#21 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#22 0x00007fffe7474a03 in CPlusPlus::IfStatementAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#23 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#24 0x00007fffe7474a03 in CPlusPlus::IfStatementAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#25 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#26 0x00007fffe7473d49 in CPlusPlus::CompoundStatementAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#27 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#28 0x00007fffe7474984 in CPlusPlus::ForStatementAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#29 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#30 0x00007fffe7473d49 in CPlusPlus::CompoundStatementAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#31 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#32 0x00007fffe7a5520c in CPlusPlus::CheckSymbols::visit(CPlusPlus::FunctionDefinitionAST*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/libCppTools.so
#33 0x00007fffe7474719 in CPlusPlus::FunctionDefinitionAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#34 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#35 0x00007fffe7474b49 in CPlusPlus::LinkageBodyAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#36 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#37 0x00007fffe7474fe4 in CPlusPlus::NamespaceAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#38 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#39 0x00007fffe7474b49 in CPlusPlus::LinkageBodyAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#40 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#41 0x00007fffe7474fe4 in CPlusPlus::NamespaceAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#42 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#43 0x00007fffe7475f49 in CPlusPlus::TranslationUnitAST::accept0(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#44 0x00007fffe746f554 in CPlusPlus::AST::accept(CPlusPlus::ASTVisitor*) ()
   from /usr/lib64/qtcreator/plugins/QtProject/../../libCPlusPlus.so.1
#45 0x00007fffe7a5261a in CPlusPlus::CheckSymbols::run() () from /usr/lib64/qtcreator/plugins/QtProject/libCppTools.so
#46 0x0000003e1126f5ad in QThreadPoolThread::run() () from /lib64/libQtCore.so.4
#47 0x0000003e1127b95c in QThreadPrivate::start(void*) () from /lib64/libQtCore.so.4
#48 0x0000003e08e07d15 in start_thread () from /lib64/libpthread.so.0
#49 0x0000003e08af248d in clone () from /lib64/libc.so.6
Comment 1 Sandro Mani 2013-10-17 17:53:46 EDT
Since this bug was reported against a now obsolete version of qt-creator, I'm closing this as WONTFIX. Please reopen if the issue still occurs, and preferably file an upstream bug report at [1] and post a link here. Thanks.

[1] https://bugreports.qt-project.org/browse/QTCREATORBUG

Note You need to log in before you can comment on or make changes to this bug.