Bug 966545 - DeleteTaskAfter uses atime to determine when a task is deleted
DeleteTaskAfter uses atime to determine when a task is deleted
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: retrace-server (Show other bugs)
el6
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Michal Toman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 09:02 EDT by Harshula Jayasuriya
Modified: 2015-03-22 20:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 06:18:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harshula Jayasuriya 2013-05-23 09:02:27 EDT
Description of problem:

DeleteTaskAfter uses atime to determine when a task is deleted. Administrative scripts may access tasks for various reasons, thus updating the atime. Since retrace-server-interact updates the mtime of the task, could DeleteTaskAfter rely on mtime instead of atime?
Comment 1 Michal Toman 2013-05-27 09:39:01 EDT
Fixed in upstream

commit 6976d3847b6d934b25bb05e500830fdbdd2c4d17
Author: Michal Toman <mtoman@redhat.com>
Date:   Mon May 27 15:37:05 2013 +0200

    use mtime instead of atime in RetraceTask.get_age()

Note You need to log in before you can comment on or make changes to this bug.