Bug 966566 - [abrt] pulseaudio-3.0-7.el7: snd_pcm_area_copy: Process /usr/bin/pulseaudio was killed by signal 6 (SIGABRT)
[abrt] pulseaudio-3.0-7.el7: snd_pcm_area_copy: Process /usr/bin/pulseaudio w...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pulseaudio (Show other bugs)
7.0
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Wim Taymans
Desktop QE
abrt_hash:5501400e87b511712f4ed042123...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 09:38 EDT by Martin Bříza
Modified: 2014-03-04 11:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-04 11:19:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (12.96 KB, text/plain)
2013-05-23 09:38 EDT, Martin Bříza
no flags Details
File: cgroup (140 bytes, text/plain)
2013-05-23 09:38 EDT, Martin Bříza
no flags Details
File: core_backtrace (1.52 KB, text/plain)
2013-05-23 09:38 EDT, Martin Bříza
no flags Details
File: dso_list (7.08 KB, text/plain)
2013-05-23 09:38 EDT, Martin Bříza
no flags Details
File: environ (1.58 KB, text/plain)
2013-05-23 09:38 EDT, Martin Bříza
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-23 09:38 EDT, Martin Bříza
no flags Details
File: maps (34.75 KB, text/plain)
2013-05-23 09:38 EDT, Martin Bříza
no flags Details
File: open_fds (2.38 KB, text/plain)
2013-05-23 09:38 EDT, Martin Bříza
no flags Details
File: proc_pid_status (1.05 KB, text/plain)
2013-05-23 09:38 EDT, Martin Bříza
no flags Details
File: var_log_messages (15.35 KB, text/plain)
2013-05-23 09:38 EDT, Martin Bříza
no flags Details

  None (edit)
Description Martin Bříza 2013-05-23 09:38:09 EDT
Description of problem:
Happened right after logging in.

Version-Release number of selected component:
pulseaudio-3.0-7.el7

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/bin/pulseaudio --start --log-target=syslog
crash_function: snd_pcm_area_copy
executable:     /usr/bin/pulseaudio
kernel:         3.9.0-0.55.el7.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (6 frames)
 #4 snd_pcm_area_copy at /usr/lib64/libasound.so.2
 #5 snd_pcm_areas_copy at /usr/lib64/libasound.so.2
 #6 snd_pcm_softvol_write_areas at /usr/lib64/libasound.so.2
 #7 snd_pcm_plugin_mmap_commit at /usr/lib64/libasound.so.2
 #8 thread_func at /usr/lib64/pulse-3.0/modules/libalsa-util.so
 #9 internal_thread_func at /usr/lib64/pulseaudio/libpulsecommon-3.0.so
Comment 1 Martin Bříza 2013-05-23 09:38:16 EDT
Created attachment 752212 [details]
File: backtrace
Comment 2 Martin Bříza 2013-05-23 09:38:19 EDT
Created attachment 752213 [details]
File: cgroup
Comment 3 Martin Bříza 2013-05-23 09:38:22 EDT
Created attachment 752214 [details]
File: core_backtrace
Comment 4 Martin Bříza 2013-05-23 09:38:25 EDT
Created attachment 752215 [details]
File: dso_list
Comment 5 Martin Bříza 2013-05-23 09:38:28 EDT
Created attachment 752216 [details]
File: environ
Comment 6 Martin Bříza 2013-05-23 09:38:30 EDT
Created attachment 752217 [details]
File: limits
Comment 7 Martin Bříza 2013-05-23 09:38:39 EDT
Created attachment 752218 [details]
File: maps
Comment 8 Martin Bříza 2013-05-23 09:38:42 EDT
Created attachment 752219 [details]
File: open_fds
Comment 9 Martin Bříza 2013-05-23 09:38:45 EDT
Created attachment 752220 [details]
File: proc_pid_status
Comment 10 Martin Bříza 2013-05-23 09:38:48 EDT
Created attachment 752221 [details]
File: var_log_messages
Comment 12 Wim Taymans 2014-02-19 08:33:27 EST
This assertion looks like it's triggered because of overlapping areas when doing a memcpy. It does not look like the source memory and the slave memory should ever use the same memory regions unless some memory corruption is at play.

Can this be reproduced? Did it ever happen again?
Comment 13 Martin Bříza 2014-02-19 08:36:53 EST
I didn't really try when I reported the bug and now it doesn't happen at all.

Note You need to log in before you can comment on or make changes to this bug.