Bug 966587 - After upgrading hypervisors from 6.3 to 6.4, spice client gets disconnected upon migration of the VM
After upgrading hypervisors from 6.3 to 6.4, spice client gets disconnected u...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.4
x86_64 Windows
high Severity high
: rc
: ---
Assigned To: Michal Privoznik
Virtualization Bugs
: ZStream
Depends On: 920441
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 10:10 EDT by Idith Tal-Kohen
Modified: 2013-11-27 19:05 EST (History)
33 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-18.el6_4.8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 08:17:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
host1 log (200.92 KB, text/plain)
2013-06-03 04:19 EDT, zhe peng
no flags Details
host2 libvirt log (90.17 KB, text/plain)
2013-06-03 04:19 EDT, zhe peng
no flags Details
host1 libvirtd log (3.24 MB, text/plain)
2013-06-08 22:50 EDT, zhe peng
no flags Details
host 2 libvirtd log (419.04 KB, text/plain)
2013-06-08 22:51 EDT, zhe peng
no flags Details
rhev-h host1 libvirtd log (1.58 MB, text/plain)
2013-06-13 06:06 EDT, zhe peng
no flags Details
rhev-h host2 libvirtd log (1.30 MB, text/plain)
2013-06-13 06:07 EDT, zhe peng
no flags Details
rhel two network host1 libvirtd log (1.88 MB, text/plain)
2013-06-13 06:08 EDT, zhe peng
no flags Details
rhel two network host2 libvirtd log (1.31 MB, text/plain)
2013-06-13 06:09 EDT, zhe peng
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 361773 None None None Never

  None (edit)
Description Idith Tal-Kohen 2013-05-23 10:10:46 EDT
This bug has been copied from bug #920441 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 6 Michal Privoznik 2013-05-23 12:00:20 EDT
We need 2 different networks, the first to be a mgmt one where the
migration will go through, the second where VNC/SPICE clients connect.
However, for better regression testing I suggest testing:

<listen type='address' address='1.2.3.4'/>

<listen type='network' network='net1'/>

<listen type='network' network='net2'/>

where net1 is the one shared with mgm infrastructure, net2 is completely
separated one. Then we should check with default values set in qemu.conf

The example picture of net1 and net2 can be found in the parent bug.
Comment 7 Michal Privoznik 2013-05-23 13:21:13 EDT
Scratch build created:

https://brewweb.devel.redhat.com/taskinfo?taskID=5819471
Comment 8 Jiri Denemark 2013-05-23 13:54:08 EDT
Additional patch is needed to fix a crasher bug in the first patch: http://post-office.corp.redhat.com/archives/rhvirt-patches/2013-May/msg00736.html
Comment 12 zhe peng 2013-06-03 04:19:14 EDT
Created attachment 756169 [details]
host1 log
Comment 13 zhe peng 2013-06-03 04:19:58 EDT
Created attachment 756170 [details]
host2 libvirt log
Comment 16 Michal Privoznik 2013-06-04 14:09:37 EDT
Just for the transcript, as I learned today, "0" *is* a valid IPv4 address. So I need to extend my patch from comment #4 .
Comment 17 Michal Privoznik 2013-06-05 12:04:48 EDT
Okay, the patch has been proposed on the upstream list:

https://www.redhat.com/archives/libvir-list/2013-June/msg00232.html
Comment 19 Michal Privoznik 2013-06-07 09:48:11 EDT
Okay, the previous patch is doomed. Here's a better version:

http://post-office.corp.redhat.com/archives/rhvirt-patches/2013-June/msg00080.html
Comment 22 zhe peng 2013-06-08 22:50:29 EDT
Created attachment 758656 [details]
host1 libvirtd log
Comment 23 zhe peng 2013-06-08 22:51:23 EDT
Created attachment 758657 [details]
host 2 libvirtd log
Comment 27 zhe peng 2013-06-13 06:06:26 EDT
Created attachment 760541 [details]
rhev-h host1 libvirtd log
Comment 28 zhe peng 2013-06-13 06:07:28 EDT
Created attachment 760542 [details]
rhev-h host2 libvirtd log
Comment 29 zhe peng 2013-06-13 06:08:54 EDT
Created attachment 760543 [details]
rhel two network host1 libvirtd log
Comment 30 zhe peng 2013-06-13 06:09:44 EDT
Created attachment 760544 [details]
rhel two network host2 libvirtd log
Comment 34 errata-xmlrpc 2013-06-18 08:17:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0951.html

Note You need to log in before you can comment on or make changes to this bug.