Bug 966772 - astromenace-1.3.1 - patches with several enhancements from upstream
astromenace-1.3.1 - patches with several enhancements from upstream
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: astromenace (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-23 18:41 EDT by Michael Kurinnoy
Modified: 2013-06-03 13:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-03 13:33:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gentoo 450158 None None None Never
Gentoo 465106 None None None Never

  None (edit)
Description Michael Kurinnoy 2013-05-23 18:41:29 EDT
Hello,

I am trying to make astromenace-1.3.1 code more stable during version 1.3.2 development, so, I made several patches for astromenace-1.3.1 source code with bugfixes from upstream code. Please, take a look. 7 patches for now.

Links for more info on Gentoo bugtracker:
https://bugs.gentoo.org/show_bug.cgi?id=450158
https://bugs.gentoo.org/show_bug.cgi?id=465106


Best regards,
Michael
Comment 1 Gwyn Ciesla 2013-05-24 09:49:32 EDT
Two questions.  

First, do you have any expectations regarding a release date of 1.3.2?

Second, are you encountering any issues with 1.3.1 that these specifically correct?

I'll still look at these and consider applying them, but your answers to those will help me prioritise.

Thanks!
Comment 2 Michael Kurinnoy 2013-05-24 11:11:40 EDT
(In reply to Jon Ciesla from comment #1)
> First, do you have any expectations regarding a release date of 1.3.2?

I still have lines in version 1.3.2 TODO list. I hope to release version 1.3.2 during this summer.


> Second, are you encountering any issues with 1.3.1 that these specifically
> correct?

1) Patch: Fixed bug that might corrupt overall game rendering (big blinking triangles over scene).

Prevent video drivers internal state corruption (true at least for amd and nvidia close source drivers on Linux and Windows).

2) Patch: Fixed overflow in VFS code.

Prevent game crash at start.


Best regards,
Michael
Comment 3 Gwyn Ciesla 2013-06-03 13:33:23 EDT
Ok, I've got this in rawhide, and will update for f19/f18/f17 as bug reports warrant.  Thanks much!

Note You need to log in before you can comment on or make changes to this bug.