Bug 966847 - glusterfs crashed while collecting the sosreport
glusterfs crashed while collecting the sosreport
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
:
Depends On: 960915
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 02:17 EDT by shishir gowda
Modified: 2016-02-17 19:19 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 960915
Environment:
Last Closed: 2014-04-17 07:42:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-05-24 02:19:22 EDT
REVIEW: http://review.gluster.org/4968 (statedump: Print entries in cb buffer in FIFO order) posted (#3) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 2 Anand Avati 2013-05-31 03:08:28 EDT
REVIEW: http://review.gluster.org/4968 (statedump: Print entries in cb buffer in FIFO order) posted (#4) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 3 Anand Avati 2013-05-31 04:49:07 EDT
COMMIT: http://review.gluster.org/4968 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit afd669d6bde01020259ec57298c8335bc2542e4a
Author: shishir gowda <sgowda@redhat.com>
Date:   Wed May 8 17:37:00 2013 +0530

    statedump: Print entries in cb buffer in FIFO order
    
    Currently cb buffer was being printed in LIFO order, which
    is was against the percieved notion of logs having older
    entries printed before newer entries in the state dumps.
    
    Re-did the loop to prevent crash as when w_index == 0, we
    would access cb[w_index - 1].
    
    Change-Id: Idd085f73fa6937e506a2a1925e42fbcfd2d9bb1c
    BUG: 966847
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/4968
    Reviewed-by: Santosh Pradhan <spradhan@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 6 Niels de Vos 2014-04-17 07:42:34 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.