Bug 966858 - Rebalance :: Renaming of files while rebalance is in progress fails with message : "File exists"
Rebalance :: Renaming of files while rebalance is in progress fails with mes...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
:
Depends On: 962400
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 02:52 EDT by shishir gowda
Modified: 2016-02-17 19:19 EST (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 962400
Environment:
Last Closed: 2014-04-17 07:42:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-05-24 02:54:37 EDT
REVIEW: http://review.gluster.org/5060 (cluster/dht: Handle linkfile creation with EEXIST error) posted (#2) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 2 Anand Avati 2013-05-31 02:59:05 EDT
REVIEW: http://review.gluster.org/5060 (cluster/dht: Handle linkfile creation with EEXIST error) posted (#3) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 3 Anand Avati 2013-05-31 09:44:49 EDT
COMMIT: http://review.gluster.org/5060 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 3c22cf86ad244f87dafd9b7a9f82331968879c15
Author: shishir gowda <sgowda@redhat.com>
Date:   Wed May 22 09:58:15 2013 +0530

    cluster/dht: Handle linkfile creation with EEXIST error
    
    If linkfile create fails with EEXISTS, then check if the file
    is a linkfile for the same file. If not, return the error
    
    Change-Id: Iab42db54422dea69de0049b5196365e65edadd91
    BUG: 966858
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5060
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 4 Anand Avati 2013-06-04 07:23:57 EDT
REVIEW: http://review.gluster.org/5141 (cluster/dht: Prevent crash in dht_linkfile_lookup) posted (#1) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 5 Anand Avati 2013-06-04 16:28:43 EDT
COMMIT: http://review.gluster.org/5141 committed in master by Anand Avati (avati@redhat.com) 
------
commit dbfe779f3049e6fbc2394bdacdb57165d51dc3f3
Author: shishir gowda <sgowda@redhat.com>
Date:   Tue Jun 4 16:43:35 2013 +0530

    cluster/dht: Prevent crash in dht_linkfile_lookup
    
    Assign local = frame->local before dereferencing
    local->linkfile.linkfile_cbk. Additionally, fail if
    op_ret is non_zero.
    
    Change-Id: I96a2f34ba29887da9ccaae38a644431cf7c43265
    BUG: 966858
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5141
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 8 Niels de Vos 2014-04-17 07:42:38 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.