Bug 966871 - [abrt] yumex-3.0.10-1.fc18: config.py:990:readStartupConfig:ConfigError: Parsing file failed: File contains parsing errors: file:///etc/yum.conf
[abrt] yumex-3.0.10-1.fc18: config.py:990:readStartupConfig:ConfigError: Pars...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
abrt_hash:62adee5b2858adf7611aaa815f5...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 03:36 EDT by Uosef
Modified: 2013-09-10 08:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 08:55:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.53 KB, text/plain)
2013-05-24 03:36 EDT, Uosef
no flags Details
File: core_backtrace (759 bytes, text/plain)
2013-05-24 03:36 EDT, Uosef
no flags Details
File: environ (232 bytes, text/plain)
2013-05-24 03:36 EDT, Uosef
no flags Details

  None (edit)
Description Uosef 2013-05-24 03:36:15 EDT
Version-Release number of selected component:
yumex-3.0.10-1.fc18

Additional info:
cmdline:        /usr/bin/python -E /usr/share/yumex/yum_childtask.py 2 True False /etc/yum.conf
dso_list:       yum-3.4.3-54.fc18.noarch
executable:     /usr/share/yumex/yum_childtask.py
kernel:         3.9.2-200.fc18.i686
uid:            0
ureports_counter: 1

Truncated backtrace:
config.py:990:readStartupConfig:ConfigError: Parsing file failed: File contains parsing errors: file:///etc/yum.conf
	[line 25]: export http_proxy

Traceback (most recent call last):
  File "/usr/share/yumex/yum_childtask.py", line 66, in <module>
    my = YumServer(debuglevel, plugins, offline, repos, yum_conf)
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 187, in __init__
    self.doLock()
  File "/usr/lib/python2.7/site-packages/yumexbackend/yum_server.py", line 268, in doLock
    yum.YumBase.doLock(self)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1997, in doLock
    if self.conf.uid != 0:
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1018, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 337, in _getConfig
    startupconf = config.readStartupConfig(fn, root, releasever)
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 990, in readStartupConfig
    raise Errors.ConfigError("Parsing file failed: %s" % e)
ConfigError: Parsing file failed: File contains parsing errors: file:///etc/yum.conf
	[line 25]: export http_proxy

Local variables in innermost frame:
e: File contains parsing errors: file:///etc/yum.conf
	[line 25]: export http_proxy
confpp_obj: <yum.parser.ConfigPreProcessor instance at 0xb6d494ac>
parser: <iniparse.compat.RawConfigParser object at 0xb6d4938c>
configfile: '/etc/yum.conf'
startupconf: <yum.config.StartupConf object at 0xb6d4936c>
releasever: None
root: '/'
Comment 1 Uosef 2013-05-24 03:36:19 EDT
Created attachment 752486 [details]
File: backtrace
Comment 2 Uosef 2013-05-24 03:36:23 EDT
Created attachment 752487 [details]
File: core_backtrace
Comment 3 Uosef 2013-05-24 03:36:26 EDT
Created attachment 752488 [details]
File: environ
Comment 4 Tim Lauridsen 2013-09-10 08:55:49 EDT
This error is caused by yum craching because syntax errors in /etc/yum.conf

Note You need to log in before you can comment on or make changes to this bug.