Bug 966874 - traceback when multipath iscsi device
traceback when multipath iscsi device
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 03:38 EDT by Jan Ščotka
Modified: 2014-12-02 14:36 EST (History)
9 users (show)

See Also:
Fixed In Version: anaconda-20.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-02 14:36:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ana log (8.20 KB, text/x-log)
2013-05-24 04:07 EDT, Jan Ščotka
no flags Details
tb 1 (2.33 MB, text/plain)
2013-05-24 04:08 EDT, Jan Ščotka
no flags Details
tb 2 (2.12 MB, text/plain)
2013-05-24 04:08 EDT, Jan Ščotka
no flags Details
storage log (1.27 MB, text/x-log)
2013-05-24 04:24 EDT, Jan Ščotka
no flags Details

  None (edit)
Description Jan Ščotka 2013-05-24 03:38:53 EDT
Description of problem:
Hi,
as participant of https://fedoraproject.org/wiki/Test_Day:2013-05-21_AnacondaNewUI_Followup#Advanced_Storage
I've tried installation on iscsi discs.
I have simulation via target utils (F19) created iscsi disc
  30 x disc
   via 2 path (2x multipath)

and it traceback with message:
Atribute Error: 'Multipath device' object has no atribute 'isMagic' - anaconda
due to F19 problem with reporting bugs directly I'm unable to report full  bug report

    Thansk&Regards
    Honza
Comment 2 Jan Ščotka 2013-05-24 03:52:46 EDT
Hi,
I forgot to mention, that discs was probably properly detected via anaconda. I was able to see all discs. It failed when I tried to select partitoning (in my case lots of disc I selected custom partitioning)
Comment 3 Jan Ščotka 2013-05-24 04:07:30 EDT
Created attachment 752492 [details]
ana log
Comment 4 Jan Ščotka 2013-05-24 04:08:07 EDT
Created attachment 752493 [details]
tb 1
Comment 5 Jan Ščotka 2013-05-24 04:08:38 EDT
Created attachment 752494 [details]
tb 2
Comment 6 Jan Ščotka 2013-05-24 04:24:17 EDT
Created attachment 752497 [details]
storage log
Comment 7 David Lehman 2013-05-24 17:13:15 EDT
What I see happening is the iscsi devices are added in two batches, each of which contains one path to each of the multipaths. When the first batch appears, the multipath tools tell us they are not multipath components (makes sense to some extent given that there is only one path to each at that point). When the second batch appears they are identified correctly as multipath components and the multipaths are activated correctly. The problem is that anaconda/blivet thinks the disks from the first batch are regular disks that can be manipulated directly, which leads to this crash.

Note You need to log in before you can comment on or make changes to this bug.