Bug 966897 - Configuration of KPI panels broken in workspace created by "Duplicate workspace" function
Configuration of KPI panels broken in workspace created by "Duplicate workspa...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: DR6
: 6.0.0
Assigned To: David Gutierrez
Jan Hrcek
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 04:46 EDT by Jan Hrcek
Modified: 2014-08-06 16:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The app was using the page logical id. to access the current dashboard instead of the persistent id. Consequence: Once cloned, the app was trying to retrieve without any success the current panel status from the original workspace. Fix: Get the cloned dashboard by its persistent identifier and also clone all the KPI referred by the dashboard panels. Result: The workspace and all its KPI panels are cloned succesfully. You can change the cloned workspace without affecting the original one.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:06:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unconfigured KPI panels in duplicated workspace (424.74 KB, image/png)
2013-05-24 04:46 EDT, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2013-05-24 04:46:49 EDT
Created attachment 752511 [details]
Unconfigured KPI panels in duplicated workspace

Description of problem:
When using "Duplicate workspace" function, the configuration of KPI panels in the duplicated workspace (and sometimes even in the original workspace) is broken. They are not configured the same as in the original workspace and require the user to choose data provider as if for newly created panel. However even after selecting the data provider nothing happens.

Version-Release number of selected component (if applicable):

How reproducible:
Seems 100% reproducible:
I reproduced the problem in the following two configurations (2 of 2 times for both configurations):
1) H2-based quickstart demo using dashboard-builder/scripts/>  ./buildandrun.sh h2
2) deployment of WAR archive on JBoss EAP 6.0 GA configured with MySQL datasource


Steps to Reproduce:
1. Starting the app with clean datasource and login with root user.
2. In the administration menu at the top Select "Showcase" workspace and click the button "Duplicate workspace" next to it.
3. Switch to the duplicate workspace "Copy of Showcase"
4. Visit all pages that contain KPI panels ("Sales opportunities") see if they are configured correctly
5. Do the same for "jBPM Dashboard" workspace and observe similar results.


Actual results:
KPI panels in the duplicated workspace are not configured the same as in the original workspace and it is impossible to fix the configuration of those panels by selecting data provider because nothing happens when data provider is selected. Also there are no errors/exceptions in the application log for either configuration.

Expected results:
The duplicated workspace should look exactly the same as the original, including the configuration of KPI panels.


Additional info:
The Duplicate Workspace function is critical for most of our dashboard builder GUI tests.
Most tests, that change the state of the application datasource use the following sequence of steps:
1. Create duplicate of a workspace
2. Make some changes and verify results
3. Delete the duplicated workspace

Therefore for testability of dashbuilder it is critical, that this issue is fixed.
Comment 1 Jan Hrcek 2013-05-24 04:49:08 EDT
Additional note: This problem seems to have started after version of Hibernate was alligned with JBoss EAP, before that it worked correctly.
Comment 2 Jan Hrcek 2013-05-24 05:53:02 EDT
It sometimes happens, that the KPI panels are configured correctly in the duplicated workspace but they become broken in the original workspace.
Comment 6 Jan Hrcek 2013-07-13 04:01:18 EDT
Ok, verified with BPMS 6.0.0.DR6 deployed on EAP 6.1

Note You need to log in before you can comment on or make changes to this bug.