Bug 966901 - it is allowed to delete Library environment
it is allowed to delete Library environment
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: David Davis
Og Maciel
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-24 04:51 EDT by Ales Dujicek
Modified: 2013-07-18 17:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:19:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-05-24 04:51:08 EDT
Description of problem:

It is possible to delete Library environment
and then there is no way to create new one because 
in web UI 'Add New Environment' button causes:

    undefined method `display_name' for nil:NilClass (NoMethodError)
    Click here for more details.

and CLI needs --prior parameter

Version-Release number of selected component (if applicable):
katello-certs-tools-1.4.2-1.el6.noarch
katello-glue-pulp-1.4.2-1.git.423.1f4d874.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.423.1f4d874.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
katello-all-1.4.2-1.git.423.1f4d874.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-1.4.2-1.git.63.00cba8e.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-glue-candlepin-1.4.2-1.git.423.1f4d874.el6.noarch
katello-configure-1.4.3-1.git.39.23db912.el6.noarch
katello-common-1.4.2-1.git.423.1f4d874.el6.noarch
katello-cli-common-1.4.2-1.git.63.00cba8e.el6.noarch
katello-1.4.2-1.git.423.1f4d874.el6.noarch


How reproducible:
always

Steps to Reproduce:
1. org create --name testorg
2. environment delete --name Library --org testorg

Actual results:
Successfully deleted environment [ Library ]

Expected results:
Can't delete the 'Library' environment
Comment 1 Garik Khachikyan 2013-05-24 09:30:52 EDT
wow! really a nasty one. I think we really need it to be fixed.

@Ales: please go on with the automation of this scenario please. tyia.
Comment 2 sthirugn@redhat.com 2013-05-28 16:41:33 EDT
After this scenario, trying to create an other environment in CLI:
# environment create --org org1 --name env1 --prior Library
Could not find environment [ Library ] within organization [ org1 ]

In UI:
Clicking "Add New Environment" in Organization's page gives the following error:

"undefined method `display_name' for nil:NilClass (NoMethodError)
 Click here for more details."
Comment 3 David Davis 2013-06-05 17:57:12 EDT
https://github.com/Katello/katello/pull/2436
Comment 4 David Davis 2013-06-06 12:04:23 EDT
As part of the testing for this bug, please make sure that organization deletion still works. Thanks.
Comment 5 David Davis 2013-06-06 12:28:11 EDT
Katello SHA

735f970fe339120b65132c1855a53514c35e5513
Comment 7 Brad Buckingham 2013-06-06 17:58:59 EDT
Mass move to ON_QA
Comment 8 Og Maciel 2013-06-06 21:06:59 EDT
katello> org create --name testorg
Successfully created org [ testorg ]
katello> environment delete --name Library --org testorg
Environment Library has a successor. Only the last environment on a path can be deleted.
katello> org info --name testorg
---------------------------------------------------------------------------------------------------------------------
                                              Organization Information
---------------------------------------------------------------------------------------------------------------------

ID                       : 3
Name                     : testorg
Description:
    None
Default Service Level    : None
Available Service Levels:
    
Default System Info Keys:
    [  ]

katello> environment info --name Library --org testorg
---------------------------------------------------------------------------------------------------------------------
                                                  Environment Info
---------------------------------------------------------------------------------------------------------------------

ID                : 6
Name              : Library
Description:
    None
Org               : testorg
Prior Environment : None
Comment 9 Og Maciel 2013-06-06 21:09:44 EDT
Verified:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10004-1.noarch
* foreman-compute-1.1.10004-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10004-1.noarch
* foreman-postgresql-1.1.10004-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-10.el6sat.noarch
* katello-all-1.4.2-10.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-7.el6sat.noarch
* katello-cli-common-1.4.2-7.el6sat.noarch
* katello-common-1.4.2-10.el6sat.noarch
* katello-configure-1.4.3-14.el6sat.noarch
* katello-configure-foreman-1.4.3-14.el6sat.noarch
* katello-foreman-all-1.4.2-10.el6sat.noarch
* katello-glue-candlepin-1.4.2-10.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-10.el6sat.noarch
* katello-glue-pulp-1.4.2-10.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.16-1.el6sat.noarch
* signo-katello-0.0.16-1.el6sat.noarch
Comment 10 Mike McCune 2013-07-18 17:19:05 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.